PAT (Advanced Level) Practice 1085 Perfect Sequence (25 分)

Given a sequence of positive integers and another positive integer p. The sequence is said to be a perfect sequence if M ≤ m × p M≤m×p Mm×p where M and m are the maximum and minimum numbers in the sequence, respectively.

Now given a sequence and a parameter p, you are supposed to find from the sequence as many numbers as possible to form a perfect subsequence.

Input Specification:

Each input file contains one test case. For each case, the first line contains two positive integers N and p, where N ( ≤ 1 0 5 ) N (≤10^5) N(105) is the number of integers in the sequence, and p ( ≤ 1 0 9 ) p (≤10^9) p(109) is the parameter. In the second line there are N positive integers, each is no greater than 1 0 9 10^9 109.

Output Specification:

For each test case, print in one line the maximum number of integers that can be chosen to form a perfect subsequence.

Sample Input:

10 8
2 3 20 4 5 1 6 7 8 9

Sample Output:

8

思路

  • 双指针
  • 注意minn*p 的大小是会超过int的,所以要使用long long比较, 否则最后一个测试点过不了
  • 原题讲的是子序列而不是子串, 所选元素是可以不连续的,因此排序后, 一个连续序列的第一个元素就是最小值,最后一个元素就是最大值

AC code

#include<iostream>
#include<algorithm>
#include<vector>
using namespace std;
using ll=long long;
int main(){
    int n,p;
    scanf("%d %d",&n,&p);
    vector<int> v(n);
    for(int i=0;i<n;i++) scanf("%d",&v[i]);
    sort(v.begin(),v.end());
    int r=0,l=0;
    int maxn,minn,ans=0;
    
    //two pointers
    while(r<n){
        maxn = v[r];
        minn = v[l];
        r++;
        while((ll)maxn>(ll)minn*p and l<r){
            l++;
            minn = v[l];  //更新最小值
        }
        ans = max(ans,r-l);
    }
    printf("%d",ans);
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值