Cow Exhibition POJ - 2184 (01背包负数处理)

题目:

"Fat and docile, big and dumb, they look so stupid, they aren't much 
fun..." 
- Cows with Guns by Dana Lyons 

The cows want to prove to the public that they are both smart and fun. In order to do this, Bessie has organized an exhibition that will be put on by the cows. She has given each of the N (1 <= N <= 100) cows a thorough interview and determined two values for each cow: the smartness Si (-1000 <= Si <= 1000) of the cow and the funness Fi (-1000 <= Fi <= 1000) of the cow. 

Bessie must choose which cows she wants to bring to her exhibition. She believes that the total smartness TS of the group is the sum of the Si's and, likewise, the total funness TF of the group is the sum of the Fi's. Bessie wants to maximize the sum of TS and TF, but she also wants both of these values to be non-negative (since she must also show that the cows are well-rounded; a negative TS or TF would ruin this). Help Bessie maximize the sum of TS and TF without letting either of these values become negative. 

Input

* Line 1: A single integer N, the number of cows 

* Lines 2..N+1: Two space-separated integers Si and Fi, respectively the smartness and funness for each cow. 

Output

* Line 1: One integer: the optimal sum of TS and TF such that both TS and TF are non-negative. If no subset of the cows has non-negative TS and non- negative TF, print 0. 
 

Sample Input

5
-5 7
8 -6
6 -3
2 1
-8 -5

Sample Output

8

Hint

OUTPUT DETAILS: 

Bessie chooses cows 1, 3, and 4, giving values of TS = -5+6+2 = 3 and TF 
= 7-3+1 = 5, so 3+5 = 8. Note that adding cow 2 would improve the value 
of TS+TF to 10, but the new value of TF would be negative, so it is not 
allowed. 

思路:

dp[i]表示Ts从-100000到100000每个值所对应的Tf的最大值;
负数的处理:将整个-100000到100000区间往正方向移动100000(0的代替值就是mid=100010); 
注意遍历顺序,怎样初始化无效值,跟有效值;

#include<stdio.h>
#include<algorithm>
#include<string.h>
using namespace std;
int dp[200100],a[10010],b[11001];
int mid=100010;
int main()
{
	int n,m,j,i,max1=-9999999;
	scanf("%d",&n);
	for(i=1; i<=n; i++)
	{
		scanf("%d %d",&a[i],&b[i]);
	}
	for(i=0; i<=2*mid; i++)
		dp[i]=-9999999;
	dp[mid]=0;/*mid相当于是实际中的0表示用
	前刚开始前0种牛a[i]总和为0时b[i]总和也必然
	为0,这个我们刚开始可以唯一确定的有效值
	后面要用这个有效值去推动其他的有效值*/
	for(i=1; i<=n; i++)
	{
		if(a[i]>=0)
		{
			for(j=2*mid; j>=a[i]; j--)/*由新状态来自哪个方向的老状态
			确定遍历的顺序:保证老状态总是先用完再更新*/
				dp[j]=max(dp[j],dp[j-a[i]]+b[i]);
		}
		else
		{
			for(j=0; j<=2*mid+a[i]; j++)
				dp[j]=max(dp[j],dp[j-a[i]]+b[i]);
		}
	}
	for(i=mid; i<=2*mid; i++)
	{
		if(dp[i]>=0)
		{
			max1=max(dp[i]+i-mid,max1);
		}
	}
	printf("%d",max1);
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值