08-图7 公路村村通

现有村落间道路的统计数据表中,列出了有可能建设成标准公路的若干条道路的成本,求使每个村落都有公路连通所需要的最低成本。
输入格式:
输入数据包括城镇数目正整数N(≤1000)和候选道路数目M(≤3N);随后的M行对应M条道路,每行给出3个正整数,分别是该条道路直接连通的两个城镇的编号以及该道路改建的预算成本。为简单起见,城镇从1到N编号。
输出格式:
输出村村通需要的最低成本。如果输入数据不足以保证畅通,则输出−1,表示需要建设更多公路。
输入样例:

6 15
1 2 5
1 3 3
1 4 7
1 5 4
1 6 2
2 3 4
2 4 6
2 5 2
2 6 6
3 4 6
3 5 1
3 6 1
4 5 10
4 6 8
5 6 3

输出样例:

12
#include <stdio.h>
#include <stdlib.h> 
 
#define MaxVertexNum 1000    /* 最大顶点数设为1000 */
#define INFINITY 65535        /* ∞设为双字节无符号整数的最大值65535*/
typedef int Vertex;         /* 用顶点下标表示顶点,为整型 */
typedef int WeightType;        /* 边的权值设为整型 */
typedef char DataType;        /* 顶点存储的数据类型设为字符型 */
 
/* 边的定义 */
typedef struct ENode *PtrToENode;
struct ENode
{
    Vertex V1, V2;      /* 有向边<V1, V2> */
    WeightType Weight;  /* 权重 */
};
typedef PtrToENode Edge;
        
/* 图结点的定义 */
typedef struct GNode *PtrToGNode;
struct GNode
{
    int Nv;  /* 顶点数 */
    int Ne;  /* 边数   */
    WeightType G[MaxVertexNum][MaxVertexNum]; /* 邻接矩阵 */
};
typedef PtrToGNode MGraph; /* 以邻接矩阵存储的图类型 */

MGraph BuildGraph();
WeightType Prim(MGraph Graph);

int main()
{
	MGraph G = BuildGraph();
	WeightType TotalWeight = Prim(G);
	if(TotalWeight == -1)printf("ERROR");
	else printf("%d", TotalWeight);
	return 0;
}
 
MGraph CreateGraph( int VertexNum )
{ /* 初始化一个有VertexNum个顶点但没有边的图 */
    Vertex V, W;
    MGraph Graph;     
    Graph = (MGraph)malloc(sizeof(struct GNode)); /* 建立图 */
    Graph->Nv = VertexNum;
    Graph->Ne = 0;
    for (V=0; V<Graph->Nv; V++)
        for (W=0; W<Graph->Nv; W++)  
            Graph->G[V][W] = INFINITY;             
    return Graph; 
}
        
void InsertEdge( MGraph Graph, Edge E )
{
     Graph->G[E->V1][E->V2] = E->Weight;    
     Graph->G[E->V2][E->V1] = E->Weight;
}
 
MGraph BuildGraph()
{
    MGraph Graph;
    Edge E;
    Vertex V;
    int Nv, i;     
    scanf("%d", &Nv);   /* 读入顶点个数 */
    Graph = CreateGraph(Nv); /* 初始化有Nv个顶点但没有边的图 */      
    scanf("%d", &(Graph->Ne));   /* 读入边数 */
    if ( Graph->Ne != 0 ) 
	{ /* 如果有边 */ 
        E = (Edge)malloc(sizeof(struct ENode)); /* 建立边结点 */ 
        for (i=0; i<Graph->Ne; i++) 
		{
            scanf("%d %d %d", &(E->V1), &(E->V2), &E->Weight);
			E->V1--; E->V2--; 
            InsertEdge( Graph, E );
        }
    }  
    return Graph;
}

Vertex FindMinDist( MGraph Graph, WeightType dist[] )
{ /* 返回未被收录顶点中dist最小者 */
    Vertex MinV, V;
    WeightType MinDist = INFINITY; 
    for (V=0; V<Graph->Nv; V++) 
	{
        if ( dist[V]!=0 && dist[V]<MinDist) 
		{/* 若V未被收录,且dist[V]更小 */
            MinDist = dist[V]; /* 更新最小距离 */
            MinV = V; /* 更新对应顶点 */
        }
    }
    if (MinDist < INFINITY) /* 若找到最小dist */
        return MinV; /* 返回对应的顶点下标 */
    else return -1;  /* 若这样的顶点不存在,返回-1作为标记 */
}
 
WeightType Prim(MGraph Graph)
{ 
    WeightType dist[MaxVertexNum], TotalWeight;
    Vertex V, W;
    int VCount;
    Edge E;    
    /* 初始化。默认初始点下标是0 */
	for (V=0; V<Graph->Nv; V++) 
	{
	/* 这里假设若V到W没有直接的边,则Graph->G[V][W]定义为INFINITY */
	   dist[V] = Graph->G[0][V]; 
    }
    TotalWeight = 0; /* 初始化权重和     */
    VCount = 0;      /* 初始化收录的顶点数 */           
    dist[0] = 0;
    VCount ++;
    while (1) 
	{
        V = FindMinDist( Graph, dist );
        if (V == -1) /* 若这样的V不存在 */
            break;   /* 算法结束 */            
        TotalWeight += dist[V];
        dist[V] = 0;
        VCount++;         
        for( W=0; W<Graph->Nv; W++ )
        {
        	if ( dist[W]!=0 && Graph->G[V][W]<INFINITY ) 
			{/* 若W是V的邻接点并且未被收录 */
                if ( Graph->G[V][W] < dist[W] ) /* 若收录V使得dist[W]变小 */
                    dist[W] = Graph->G[V][W]; /* 更新dist[W] */
            }
		}
    } 
    if ( VCount < Graph->Nv ) /* MST中收的顶点不到|V|个 */
       TotalWeight = -1;
    return TotalWeight;   /* 算法执行完毕,返回最小权重和或错误标记 */
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值