09-排序3 Insertion or Heap Sort

According to Wikipedia:
Insertion sort iterates, consuming one input element each repetition, and growing a sorted output list. Each iteration, insertion sort removes one element from the input data, finds the location it belongs within the sorted list, and inserts it there. It repeats until no input elements remain.
Heap sort divides its input into a sorted and an unsorted region, and it iteratively shrinks the unsorted region by extracting the largest element and moving that to the sorted region. it involves the use of a heap data structure rather than a linear-time search to find the maximum.
Now given the initial sequence of integers, together with a sequence which is a result of several iterations of some sorting method, can you tell which sorting method we are using?
Input Specification:
Each input file contains one test case. For each case, the first line gives a positive integer N (≤100). Then in the next line, N integers are given as the initial sequence. The last line contains the partially sorted sequence of the N numbers. It is assumed that the target sequence is always ascending. All the numbers in a line are separated by a space.
Output Specification:
For each test case, print in the first line either “Insertion Sort” or “Heap Sort” to indicate the method used to obtain the partial result. Then run this method for one more iteration and output in the second line the resulting sequence. It is guaranteed that the answer is unique for each test case. All the numbers in a line must be separated by a space, and there must be no extra space at the end of the line.
Sample Input 1:

10
3 1 2 8 7 5 9 4 6 0
1 2 3 7 8 5 9 4 6 0

Sample Output 1:

Insertion Sort
1 2 3 5 7 8 9 4 6 0

Sample Input 2:

10
3 1 2 8 7 5 9 4 6 0
6 4 5 1 0 3 2 7 8 9

Sample Output 2:

Heap Sort
5 4 3 1 0 2 6 7 8 9
#include <stdio.h>
#include <stdlib.h>
typedef int ElementType;
#define MAX 100
int B[MAX];

int Judge(ElementType A[], int N);
void InsertionSort( ElementType B[], int P ); 
void HeapSort( ElementType A[], int N );

int main() 
{
	int n, P, A[MAX];
	scanf("%d", &n);
	for(int i=0; i<n; i++)scanf("%d", &A[i]);
	P = Judge(A, n); 
	if(P == -1)
	{
		printf("Heap Sort\n");
		HeapSort(A, n);
		for(int i=0; i<n; i++)printf("%d ", A[i]);
	}
	else
	{
		printf("Insertion Sort\n");
		InsertionSort(B, P);
		for(int i=0; i<n; i++)printf("%d ", B[i]);
	}
	return 0;
}

int Judge(ElementType A[], int N)
{
	int i, t;
	for(i=0; i<N; i++)scanf("%d", &B[i]);
	for(i=0; i<N-1; i++)
	{
		if(B[i] < B[i+1])continue;
		else break;
	}
	t = ++i;
	for(; i<N; i++)
		if(B[i] != A[i])
			return -1;
	return t;
} 

void InsertionSort( ElementType A[], int P )
{ /* 插入排序 */
    int i;
    ElementType Tmp;     
    Tmp = A[P]; /* 取出未排序序列中的第一个元素*/
    for ( i=P; i>0 && A[i-1]>Tmp; i-- )
        A[i] = A[i-1]; /*依次与已排序序列中元素比较并右移*/
    A[i] = Tmp; /* 放进合适的位置 */
}

void Swap( ElementType *a, ElementType *b )
{
    ElementType t = *a; 
	*a = *b; 
	*b = t;
}

void PercDown( ElementType A[], int p, int N )
{/* 将N个元素的数组中以A[p]为根的子堆调整为最大堆 */
    int Parent, Child;
    ElementType X; 
    X = A[p]; /* 取出根结点存放的值 */
    for( Parent=p; (Parent*2+1)<N; Parent=Child ) 
	{
        Child = Parent * 2 + 1;
        if( (Child!=N-1) && (A[Child]<A[Child+1]) )
            Child++;  /* Child指向左右子结点的较大者 */
        if( X >= A[Child] ) break; /* 找到了合适位置 */
        else  /* 下滤X */
            A[Parent] = A[Child];
    }
    A[Parent] = X;
}
 
void HeapSort( ElementType A[], int N ) 
{ /* 堆排序 */
    int i;      
    for ( i=N/2-1; i>=0; i-- )/* 建立最大堆 */
        PercDown( A, i, N );     
	/* 删除最大堆顶 */
	for ( i=N-1; i>0; i-- )
    {
    	Swap( &A[0], &A[i] );
    	PercDown( A, 0, i );
    	if(A[i] != B[i])break;
	}	
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值