1146 Topological Order (25 分)判断哪些序列不是拓扑序列

This is a problem given in the Graduate Entrance Exam in 2018: Which of the following is NOT a topological order obtained from the given directed graph? Now you are supposed to write a program to test each of the options.

在这里插入图片描述

Input Specification:

Each input file contains one test case. For each case, the first line gives two positive integers N (≤ 1,000), the number of vertices in the graph, and M (≤ 10,000), the number of directed edges. Then M lines follow, each gives the start and the end vertices of an edge. The vertices are numbered from 1 to N. After the graph, there is another positive integer K (≤ 100). Then K lines of query follow, each gives a permutation of all the vertices. All the numbers in a line are separated by a space.

Output Specification:

Print in a line all the indices of queries which correspond to “NOT a topological order”. The indices start from zero. All the numbers are separated by a space, and there must no extra space at the beginning or the end of the line. It is graranteed that there is at least one answer.

Sample Input:

6 8
1 2
1 3
5 2
5 4
2 3
2 6
3 4
6 4
5
1 5 2 3 6 4
5 1 2 6 3 4
5 1 2 3 6 4
5 2 1 6 3 4
1 2 3 4 5 6

Sample Output:

3 4

题意:先输入顶点数和边数,再输入边的情况,再输入查询次数,和每次查询所输入的拓扑序列
思路:拓扑排序可能会很容易想到栈,但是看了柳神的博客以后才发现用一个二维vector邻接矩阵和一个一维的in数组表示每个顶点的入度就能搞定。这里的几个坑点是最好设置新的vector tin(in,in+n+1)这里一定要加一,否则就出错了,还有一个坑点是每个数之间要空格输出,应该要将控制空格的标识flag放在for循环的外层,放到内存一直报格式错误。一个比较巧妙的点是只要将n个顶点遍历过去,判断他的入度是不是0,引入judge标识,不等于0就用增强for循环把与这个点相邻的点的入度都减一,最后只需要看judge是不是为一就可以了,为一就说明是拓扑序列,continue,不唯一就打印出来。

#include<iostream>
#include<cstdio>
#include<stack> 
#include<queue>
#include<vector>
#include<algorithm>
#include<cstring>
#include<string>
#include<cmath>
#include<set>
#include<map>
#include<cctype>
#include<cstdlib>
#include<ctime>
#include<unordered_map>

using namespace std;

int main() {
	int n,m,c;
	vector<int> v[1010];
	//这个flag=0要放在外面 
	int flag = 0;
	int in[1010];
	scanf("%d%d",&n,&m);
	for(int i = 0;i < m;i++) {
		int a,b;
		scanf("%d%d",&a,&b);
		v[a].push_back(b);
		in[b]++;
	}
	int k;
	scanf("%d",&k);
	for(int i = 0;i < k;i++) {
		int judge = 1;
		//vector最好设置大一点 
		vector<int> tin(in,in + n + 1);
		for(int i = 0;i < n;i++) {
			scanf("%d",&c);
			if(tin[c] != 0) judge = 0;
			for(int it : v[c]) tin[it]--; 
		}
		if(judge == 0) {
			printf("%s%d", flag == 1 ? " ": "", i);
			flag = 1;
		} else if (judge == 1) {
			continue;
		}
	}
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值