1033. To Fill or Not to Fill (25) 贪心算法

1033. To Fill or Not to Fill (25)

时间限制
100 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
ZHANG, Guochuan

With highways available, driving a car from Hangzhou to any other city is easy. But since the tank capacity of a car is limited, we have to find gas stations on the way from time to time. Different gas station may give different price. You are asked to carefully design the cheapest route to go.

Input Specification:

Each input file contains one test case. For each case, the first line contains 4 positive numbers: Cmax (<= 100), the maximum capacity of the tank; D (<=30000), the distance between Hangzhou and the destination city; Davg (<=20), the average distance per unit gas that the car can run; and N (<= 500), the total number of gas stations. Then N lines follow, each contains a pair of non-negative numbers: Pi, the unit gas price, and Di (<=D), the distance between this station and Hangzhou, for i=1,...N. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the cheapest price in a line, accurate up to 2 decimal places. It is assumed that the tank is empty at the beginning. If it is impossible to reach the destination, print "The maximum travel distance = X" where X is the maximum possible distance the car can run, accurate up to 2 decimal places.

Sample Input 1:
50 1300 12 8
6.00 1250
7.00 600
7.00 150
7.10 0
7.20 200
7.50 400
7.30 1000
6.85 300
Sample Output 1:
749.17
Sample Input 2:
50 1300 12 2
7.10 0
7.00 600
Sample Output 2:
The maximum travel distance = 1200.00

思路:输入后将加油站按距离排序。题目假设开始没有油,所以如果没有距离为0的加油站则直接输出0。从当前加油站往前找比当前价格低的加油站,如果找到则加上刚好到那个加油站的油,如果没有,则把油箱加满,到能走到的价格最低的加油站。用cnt检查是否能走到下一个加油站


#include<cstdio> 
#include<algorithm>
using namespace std;

typedef struct nod{
	double pr;
	double dis;
}nod;

nod nods[500];

double cmax,d,davg;
int n;

bool cmp(nod a,nod b){
	return a.dis<b.dis;
}

int main(){
	scanf("%lf %lf %lf %d",&cmax,&d,&davg,&n);
	for(int i=0;i<n;i++){
		scanf("%lf %lf",&nods[i].pr,&nods[i].dis);
	}
	nods[n].dis=d;nods[n].pr=0.0;
	sort(nods,nods+n+1,cmp);
	double ttcost=0.0,lefto=0.0;
	double maxdis=cmax*davg;
	double nowdis=0.0;
	int dangqianzhan=0,next;
	if(nods[0].dis==0.0){
    	while(nowdis<d){
	    	double nowp=nods[dangqianzhan].pr;
	    	next=9999;
	    	int cnt=0;
		    for(int i=dangqianzhan+1;i<=n&&nods[i].dis-nowdis<=maxdis&&nods[i].dis<=d;i++){
		    	cnt++;
		    	if(nods[i].pr<nowp){
		    		next=i;
		    		break;
				}
			}
			if(cnt==0) break;
			if(next==9999){
				double minp=99999999.0;
				for(int i=dangqianzhan+1;i<=n&&nods[i].dis-nowdis<=maxdis&&nods[i].dis<=d;i++){
		    		if(nods[i].pr<minp){
		    			minp=nods[i].pr;
		    			next=i;
					}
				}
				ttcost+=(cmax-lefto)*nods[dangqianzhan].pr;
				lefto=cmax-(nods[next].dis-nowdis)/davg;
				dangqianzhan=next;
				nowdis=nods[dangqianzhan].dis;
			}
			else{
				double needgo=nods[next].dis-nowdis;
				double needo=needgo/davg;
				ttcost+=(needo-lefto)*nods[dangqianzhan].pr;
				lefto=0.0;
				nowdis=nods[next].dis;
				dangqianzhan=next;
			}
    	}
    	if(nowdis==d)printf("%.2lf",ttcost);
    	else printf("The maximum travel distance = %.2lf",nowdis+maxdis);
    }
    else printf("The maximum travel distance = 0.00");
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值