【OJ】贪心算法:To Fill or Not to Fill——怀疑人生

题目描述

With highways available, driving a car from Hangzhou to any other city is easy. But since the tank capacity of a car is limited, we have to find gas stations on the way from time to time. Different gas station may give different price. You are asked to carefully design the cheapest route to go.

输入

Each input file contains one test case. For each case, the first line contains 4 positive numbers: Cmax (<= 100), the maximum capacity of the tank; D (<=30000), the distance between Hangzhou and the destination city; Davg (<=20), the average distance per unit gas that the car can run; and N (<= 500), the total number of gas stations. Then N lines follow, each contains a pair of non-negative numbers: Pi, the unit gas price, and Di (<=D), the distance between this station and Hangzhou, for i=1,...N. All the numbers in a line are separated by a space.

输出

For each test case, print the cheapest price in a line, accurate up to 2 decimal places. It is assumed that the tank is empty at the beginning. If it is impossible to reach the destination, print "The maximum travel distance = X" where X is the maximum possible distance the car can run, accurate up to 2 decimal places.

样例输入

59 525 19 2
3.00 314
3.00 0

样例输出

82.89

这里还有一个更好的测试用例

提示

该题目所要解决的问题是:给定若干加油站信息,问能否驾驶汽车行驶一定的距离。如果能够行驶完全程,则计算最小花费。若不能行驶完全程,则最远能够行驶多长距离。

拿到这一题,首先判断汽车是否能够行驶到终点。什么情况下汽车无法行驶到终点呢?两种情况:起点根本就没有加油站,汽车无法启动;或者中途两个加油站之间的距离大于加满油后汽车能够行驶的最大距离。前者汽车行驶的最大距离为0.00,而后者最大距离为当前加油站的距离加上在这个加油站加满油后能够行驶的最大距离。在这里,需要将加油站按到杭州的距离从小到大排序。

接下来在能够行驶到终点的情况下计算最小花费。我们首先从路程来考虑,如果在路上,我们能够使用最便宜的汽油,当然就在那个加油站加油了。所以从起点开始遍历每个加油站。假设遍历到了第i个加油站,我们现在来判断在加油站i应该加多少油。设当前汽车离杭州的距离为curLen,当前加油站离杭州的距离为nodes[i].dis,加满油以后汽车能够行驶的最大距离为(dis=cmax*len)。这样就有node[i].dis <= curLen <= nodes[i].dis+dis,否则的话第i个加油站的油是不起作用的。于是在第i个加油站的作用范围内寻找有没有更为便宜的加油站,如果有,则下次使用这个加油站的油(j),这次汽车应该行驶到这个加油站,即touch=nodes[j].dis。如果没有找到更为便宜的加油站则可以在第i个加油站加满油,即touch=nodes[i].dis+dis。然后判断下次应该行驶到的距离与当前距离的关系,如果下次应当行驶到的距离大于当前距离,则汽车行驶,否则不动(也就是说上个加油站的油更便宜,后一个加油站也便宜,根本就不需要在当前加油站加油)。

我的想法

我认为每次到一个加油站,在在这个加油站加满后可以到的所有加油站中(包括此加油站),若此加油站价格最低,那么就加满,然后去下一站,如果这个加油站不是价格最低,那么把油加到可以到达下一个价格比此加油站底的加油站,中间的不加油,因为可以到,且价格比之前的高,那么没必要加油,而下一个价格比第一个加油站低的加油站,可以加油然后再做决策。

#include <iostream>
#include <map>
#include <algorithm>
#include <stdio.h>
#include <iomanip>
using namespace std;
struct gs{
    int distance;
    double price;
}station[502];
int far[502],minp[502],lessp[502];
bool cmp(gs a,gs b){
return a.distance<b.distance;
}
int main()
{
    double C,Davg,fulldistance,sum=0,money=0,c=0;
    int N,D;
    while(cin>>C>>D>>Davg>>N){
        fulldistance=C*Davg;
        //cout<<"fulldistance:"<<fulldistance<<endl;
        for(int i=0;i<N;i++){cin>>station[i].price>>station[i].distance;}
        station[N].distance=D;
        station[N].price=0;
        sort(station,station+N,cmp);
        //for(int i=0;i<N;i++){cout<<station[i].price<<station[i].distance<<endl;}
        if(station[0].distance!=0){
            cout<<"The maximum travel distance = 0";
            return 0;
        }
        for(int i=0;i<N;i++){
            if(station[i+1].distance-station[i].distance>fulldistance){
                cout<<"The maximum travel distance = "<<station[i].distance+fulldistance;
                return 0;
            }
            int temp=0,mins=i,lesp=i,flag=true;
            for(int j=1;j<=N-i;j++){
                if(station[i+j].distance<=station[i].distance+fulldistance)temp++;
                else break;
                if(station[i+j].price<station[mins].price)mins=i+j;
                if(station[i+j].price<station[i].price && flag){lesp=i+j;flag=false;}
            }
            minp[i]=mins;
            far[i]=temp;
            lessp[i]=lesp;
        }
        //for(int i=0;i<=N;i++){cout<< i <<' '<<station[i].distance<<' '<<station[i].price<<' '<<far[i]<<' '<<minp[i]<<' '<<lessp[i]<<endl;}
        //所以策略就是如果此站是在该站加满后可以到达站点种价格最低的 加满
        //否则加到可以到第一个遇到小于该站价格的地方
        //getchar();
        //getchar();
        int i;
        for(i=0;i<N;){
            if(station[minp[i]].price==station[i].price){//此站是在该站加满后可以到达站点种价格最低的 加满 到下一站
                money+=(C-c)*station[i].price;//更新花费
                i++;
                sum=station[i].distance;//开到下一站
                c=C-(station[i].distance-station[i-1].distance)/Davg;//更新油量
            }
            else{//否则加到可以到第一个遇到小于该站价格的地方 到下一站
                int k=lessp[i];//直接加到下一站
                int d = station[k].distance-station[i].distance;
                double needc=d/Davg;//开到下一站需要的油量
                if(c>=needc){c-=needc;}
                else{money+=(needc-c)*station[i].price;c=0;}
                i=k;
                sum=station[i].distance;
            }
            //cout<<"sum:"<<sum<<";"<<"money:"<<money<<";"<<"c:"<<c<<endl;
        }
        cout<<setiosflags(ios::fixed)<<setprecision(2)<<money<<endl;
    }
    return 0;
}

每一个测试用例我都通过了!为什么还是NC!

逻辑上我也觉得没错啊!求大神指教!

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值