1137. Final Grading (25)

1137. Final Grading (25)

时间限制
100 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

For a student taking the online course "Data Structures" on China University MOOC (http://www.icourse163.org/), to be qualified for a certificate, he/she must first obtain no less than 200 points from the online programming assignments, and then receive a final grade no less than 60 out of 100. The final grade is calculated by G = (Gmid-termx 40% + Gfinalx 60%) if Gmid-term > Gfinal, or Gfinal will be taken as the final grade G. Here Gmid-term and Gfinal are the student's scores of the mid-term and the final exams, respectively.

The problem is that different exams have different grading sheets. Your job is to write a program to merge all the grading sheets into one.

Input Specification:

Each input file contains one test case. For each case, the first line gives three positive integers: P , the number of students having done the online programming assignments; M, the number of students on the mid-term list; and N, the number of students on the final exam list. All the numbers are no more than 10,000.

Then three blocks follow. The first block contains P online programming scores Gp's; the second one contains M mid-term scores Gmid-term's; and the last one contains N final exam scores Gfinal's. Each score occupies a line with the format: StudentID Score, where StudentID is a string of no more than 20 English letters and digits, and Score is a nonnegative integer (the maximum score of the online programming is 900, and that of the mid-term and final exams is 100).

Output Specification:

For each case, print the list of students who are qualified for certificates. Each student occupies a line with the format:

StudentID Gp Gmid-term Gfinal G

If some score does not exist, output "-1" instead. The output must be sorted in descending order of their final grades (G must be rounded up to an integer). If there is a tie, output in ascending order of their StudentID's. It is guaranteed that the StudentID's are all distinct, and there is at least one qualified student.

Sample Input:
6 6 7
01234 880
a1903 199
ydjh2 200
wehu8 300
dx86w 220
missing 400
ydhfu77 99
wehu8 55
ydjh2 98
dx86w 88
a1903 86
01234 39
ydhfu77 88
a1903 66
01234 58
wehu8 84
ydjh2 82
missing 99
dx86w 81
Sample Output:
missing 400 -1 99 99
ydjh2 200 98 82 88
dx86w 220 88 81 84
wehu8 300 55 84 84
题意:上过陈越老师的mooc的话肯定一看就知道啦。要有期末成绩的话首先要在题库中做满200分的题,这是门槛,然后先期中考试,再期末考试,如果期末考试成绩比期中考试成绩高,则最后成绩取期末考试成绩,否则期中考试成绩占40%,期末考试成绩占60%,最后按最终成绩排序。

思路:用一个map存储满200分的nod在nods里的位置,为了方便,从1开始存储,各分数默认-1,所以map里为0的人就不用管。输入期中考试成绩的时候先检查位置是否为0,然后要看是否比已存在的分数高(没试过这个操作是否多余),输入期末考试成绩同理。最后计算各同学的最终成绩,不合格可以直接记为-1,方便排序,然后用sort排序。要注意cmp函数里当两个人都是-1时直接返回false,此时没必要再去比较id,会超时。默认输出全部同学,遇到成绩为-1就break;


#include<cstdio>
#include<cstring>
#include<map>
#include<string>
#include<iostream>
#include<algorithm>
using namespace std;

typedef struct nod{
	string id;
	int poins;
	int mid=-1,fin=-1,g=-1;
}nod;

nod nods[10001];

map<string,int>mp;

int p,m,n;

bool cmp(nod a,nod b){
	if(a.g!=b.g) return a.g>b.g;
	if(a.g==-1) return false;
	return a.id<b.id;
}

int main(){
	char tid[21];
	int ts,cnt=1;
	scanf("%d %d %d",&p,&m,&n);
	for(int i=0;i<p;i++){
		scanf("%s %d",tid,&ts);
		if(ts>=200){
			nods[cnt].id=tid;
			mp[tid]=cnt++;
			nods[cnt-1].poins=ts;
		}
	}
	for(int i=0;i<m;i++){
		scanf("%s %d",tid,&ts);
		if(mp[tid]!=0){
			if(ts>nods[mp[tid]].mid){
				nods[mp[tid]].mid=ts;
			}
		}
	}
	for(int i=0;i<n;i++){
		scanf("%s %d",tid,&ts);
		if(mp[tid]!=0){
			if(ts>nods[mp[tid]].fin){
				nods[mp[tid]].fin=ts;
			}
		}
	}
	for(int i=1;i<cnt;i++){
		if(nods[i].fin>=nods[i].mid){
			nods[i].g=nods[i].fin;
		}
		else{
			double t=nods[i].mid*4+nods[i].fin*6;
			t=t/10;t+=0.5;
			nods[i].g=t;
		}
		
		if(nods[i].g<60) nods[i].g=-1;
	}
	sort(nods+1,nods+cnt,cmp);
	for(int i=1;i<cnt;i++){
		if(nods[i].g==-1) break;
		printf("%s %d %d %d %d\n",nods[i].id.c_str(),nods[i].poins,nods[i].mid,nods[i].fin,nods[i].g);
	}
	
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值