1102 Invert a Binary Tree (25分)

The following is from Max Howell @twitter:

Google: 90% of our engineers use the software you wrote (Homebrew), but you can't invert a binary tree on a whiteboard so fuck off.

Now it's your turn to prove that YOU CAN invert a binary tree!

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤10) which is the total number of nodes in the tree -- and hence the nodes are numbered from 0 to N−1. Then N lines follow, each corresponds to a node from 0 to N−1, and gives the indices of the left and right children of the node. If the child does not exist, a - will be put at the position. Any pair of children are separated by a space.

Output Specification:

For each test case, print in the first line the level-order, and then in the second line the in-order traversal sequences of the inverted tree. There must be exactly one space between any adjacent numbers, and no extra space at the end of the line.

Sample Input:

8
1 -
- -
0 -
2 7
- -
- -
5 -
4 6

Sample Output:

3 7 2 6 4 0 5 1
6 5 7 4 3 2 0 1

常规水题。。。。

#include <iostream>
#include <map>
#include <vector>
#include <queue>
#include <algorithm>
#include <string.h>

using namespace std;

const int maxn = 15;

char tree[maxn][2];
char itree[maxn][2];

int leve[maxn];
int lcnt;

int inodr[maxn];
int icnt;

void invert(int root) {
    if (tree[root][0] == '-' && tree[root][1] == '-') {
        return;
    }
    if (tree[root][0] != '-') {
        invert(tree[root][0] - '0');
    }
    if (tree[root][1] != '-') {
        invert(tree[root][1] - '0');
    }
    swap(tree[root][0], tree[root][1]);
}

void inorder(int root) {
    if (tree[root][0] == '-' && tree[root][1] == '-') {
        // cout << root << endl;
        inodr[icnt++] = root;
        return;
    }
    if (isdigit(tree[root][0])) {
        inorder(tree[root][0] - '0');
    }
    inodr[icnt++] = root;
    // cout << root << endl;
    if (isdigit(tree[root][1])) {
        inorder(tree[root][1] - '0');
    }
}

void level(int root) {
    int cur = root;
    queue<int> q;
    q.push(root);
    while(!q.empty()) {
        cur = q.front();
        // cout << cur << endl;
        leve[lcnt++] = cur;
        q.pop();
        if (tree[cur][0] != '-') {
            q.push(tree[cur][0] - '0');
        }
        if (tree[cur][1] != '-') {
            q.push(tree[cur][1] - '0');
        }
    }
}

int main() {
    int N;
    lcnt = 0;
    icnt = 0;
    memset(leve, -1, sizeof(leve));
    memset(inodr, -1, sizeof(inodr));
    scanf("%d\n", &N);
    int root = N * (N - 1) / 2;
    memset(tree, '-', sizeof(tree));
    for(int i = 0; i < N; ++i) {
        scanf("%c %c\n", tree[i], tree[i] + 1);
        // cout << root << "-" << tree[i][0] << "-" << tree[i][1] << endl;
        if (isdigit(tree[i][0])) {
            root -= (tree[i][0] - '0');
        }
        if (isdigit(tree[i][1])) {
            root -= (tree[i][1] - '0');
        }
    }
    invert(root);
    level(root);
    inorder(root);    
    for(int i = 0; i < lcnt; ++i) {
        cout << leve[i] << " \n"[i == lcnt - 1];
    }
    for(int i = 0; i < icnt; ++i) {
        cout << inodr[i] << " \n"[i == icnt - 1];
    }

    // cout << root << endl;
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值