Maximum Subsequence Sum (25 分)

Given a sequence of K integers A continuous subsequence is defined to be where 1≤i≤j≤K. The Maximum Subsequence is the continuous subsequence which has the largest sum of its elements. For example, given sequence { -2, 11, -4, 13, -5, -2 }, its maximum subsequence is { 11, -4, 13 } with the largest sum being 20.

Now you are supposed to find the largest sum, together with the first and the last numbers of the maximum subsequence.

Input Specification:

Each input file contains one test case. Each case occupies two lines. The first line contains a positive integer K (≤10000). The second line contains K numbers, separated by a space.

Output Specification:

For each test case, output in one line the largest sum, together with the first and the last numbers of the maximum subsequence. The numbers must be separated by one space, but there must be no extra space at the end of a line. In case that the maximum subsequence is not unique, output the one with the smallest indices i and j (as shown by the sample case). If all the K numbers are negative, then its maximum sum is defined to be 0, and you are supposed to output the first and the last numbers of the whole sequence.

Sample Input:
10
-10 1 2 3 4 -5 -23 3 7 -21
Sample Output:
10 1 4

code

#include <stdio.h>
#include <stdlib.h>

void maxSubsequence(int arr[],int n);

int main()
{
    int k;
    scanf("%d",&k);
    int num[k];
    for(int i=0;i<k;i++)
    {
        scanf("%d",&num[i]);
    }
    maxSubsequence(num,k);
    return 0;
}

/*求最大子列和*/
void maxSubsequence(int arr[],int n)
{
    int maxSum,thisSum,frist,last,a;//first和last分别为最大子列的第一个和最后一个数,其中a用来记录最后一个数的在数组里的下标
    maxSum = thisSum = 0;
    for(int i =0;i<n;i++)
    {
        thisSum+=arr[i];
        if(thisSum>maxSum)
        {
            last = arr[i]; //每次maxSum更新时,更新last
            a=i;
            maxSum = thisSum;
        }
        if(thisSum<0)
        {
            thisSum = 0;
        }
    }
/*当最大子列和为0时,有两种情况,全为负数,或者存在0和负数,下面对着两种情况进行判断*/
    if(maxSum==0)
    {
        for(int i =0;i<n;i++)
        {
            if(arr[i]==0)
            {
                frist = last =0 ;
                break;
            }else
            {
                frist = arr[0];
                last = arr[n-1];
            }
        }
    }else
    {
        /*当最大子列和不为0时,求最大子列的第一个数字*/
        thisSum = 0;
        for(int j=a;j>=0;j--)
        {
            thisSum += arr[j];
            if(thisSum == maxSum)
            {
                frist = arr[j];
            }
        }
    }
    printf("%d %d %d\n",maxSum,frist,last);
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值