1006 Sign In and Sign Out (25 分)

题目来源PAT
At the beginning of every day, the first person who signs in the computer room will unlock the door, and the last one who signs out will lock the door. Given the records of signing in’s and out’s, you are supposed to find the ones who have unlocked and locked the door on that day.

Input Specification:

Each input file contains one test case. Each case contains the records for one day. The case starts with a positive integer M, which is the total number of records, followed by M lines, each in the format:

ID_number Sign_in_time Sign_out_time
where times are given in the format HH:MM:SS, and ID_number is a string with no more than 15 characters.

Output Specification:

For each test case, output in one line the ID numbers of the persons who have unlocked and locked the door on that day. The two ID numbers must be separated by one space.

Note: It is guaranteed that the records are consistent. That is, the sign in time must be earlier than the sign out time for each person, and there are no two persons sign in or out at the same moment.

Sample Input:
3
CS301111 15:30:28 17:00:10
SC3021234 08:00:00 11:25:25
CS301133 21:45:00 21:58:40
Sample Output:
SC3021234 CS301133
算法&程序

1.选择结构数组存储
2.将字符串的比较简化为整数比较,将时间都计算为秒数后再存储比较。

#include <stdio.h>
#include <stdlib.h>
#define MaxSize 16
#define TimeLength 9

struct UserSign{
    char ID[MaxSize];
    int SignIn;
    int SignOut;
};

int main()
{
    struct UserSign *U;
    int M,min,max,k,m;
    char T1[TimeLength],T2[TimeLength];
    scanf("%d",&M);
    U = (struct UserSign *)malloc(sizeof(struct UserSign)*M);

    for(int i=0;i<M;i++)
    {
        scanf("\n%s %s %s",U[i].ID,T1,T2);
        //字符串转化为整数时,尽量减少乘法运算,提高效率
        U[i].SignIn = (((T1[0]-'0')*10+T1[1]-'0')*60+(T1[3]-'0')*10+T1[4]-'0')*60+(T1[6]-'0')*10+T1[7]-'0';
        U[i].SignOut = (((T2[0]-'0')*10+T2[1]-'0')*60+(T2[3]-'0')*10+T2[4]-'0')*60+(T2[6]-'0')*10+T2[7]-'0';
    }
    min = U[0].SignIn;
    max = U[0].SignOut;
    k=m=0;
    for(int i=1;i<M;i++)
    {
        if(min>U[i].SignIn)
        {
            min = U[i].SignIn;
            k=i;
        }

        if(max<U[i].SignOut)
        {
            max = U[i].SignOut;
            m=i;
        }
    }
    printf("%s %s",U[k].ID,U[m].ID);
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
"Place sign in" 错误通常出现在使用 Spring Security 进行身份验证的应用程序中。这通常意味着用户没有通过身份验证并且没有正确的会话信息。可能的原因是在使用 HttpSession 时,没有正确地配置 Spring Security。 为了解决这个问题,你可以尝试以下步骤: 1. 确保在 Spring Security 配置中启用了会话管理: ```java @Configuration @EnableWebSecurity public class SecurityConfig extends WebSecurityConfigurerAdapter { @Override protected void configure(HttpSecurity http) throws Exception { http .sessionManagement() .sessionCreationPolicy(SessionCreationPolicy.ALWAYS); } } ``` 2. 确保使用 Spring Security 进行身份验证时,正确地配置了 HttpSession: ```java @Configuration @EnableWebSecurity public class SecurityConfig extends WebSecurityConfigurerAdapter { @Override protected void configure(HttpSecurity http) throws Exception { http .sessionManagement() .sessionCreationPolicy(SessionCreationPolicy.ALWAYS) .and() .formLogin() .loginPage("/login") .permitAll() .and() .logout() .logoutSuccessUrl("/") .permitAll() .and() .authorizeRequests() .antMatchers("/admin/**").hasRole("ADMIN") .anyRequest().authenticated(); } @Override protected void configure(AuthenticationManagerBuilder auth) throws Exception { auth .inMemoryAuthentication() .withUser("user").password("password").roles("USER") .and() .withUser("admin").password("password").roles("USER", "ADMIN"); } } ``` 3. 确保在使用 HttpSession 时,正确地配置了 Spring Boot 的属性: ```properties # application.properties server.servlet.session.timeout=30m ``` 如果你仍然遇到问题,可能需要进一步检查你的代码和配置是否正确。

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值