C/B - Six Degrees of Cowvin Bacon(最短路径算法)

43 篇文章 0 订阅
The cows have been making movies lately, so they are ready to play a variant of the famous game "Six Degrees of Kevin Bacon".

The game works like this: each cow is considered to be zero degrees of separation (degrees) away from herself. If two distinct cows have been in a movie together, each is considered to be one 'degree' away from the other. If a two cows have never worked together but have both worked with a third cow, they are considered to be two 'degrees' away from each other (counted as: one degree to the cow they've worked with and one more to the other cow). This scales to the general case.

The N (2 <= N <= 300) cows are interested in figuring out which cow has the smallest average degree of separation from all the other cows. excluding herself of course. The cows have made M (1 <= M <= 10000) movies and it is guaranteed that some relationship path exists between every pair of cows.
Input
* Line 1: Two space-separated integers: N and M

* Lines 2..M+1: Each input line contains a set of two or more space-separated integers that describes the cows appearing in a single movie. The first integer is the number of cows participating in the described movie, (e.g., Mi); the subsequent Mi integers tell which cows were.
Output
* Line 1: A single integer that is 100 times the shortest mean degree of separation of any of the cows.
Sample Input
4 2
3 1 2 3
2 3 4
Sample Output
100


牛与牛

#include <iostream>
#include<cstring>
using namespace std;
const double INF=0x3f3f3f;
const int maxn=305;
int dis[maxn];
int vis[maxn];
int map[maxn][maxn];
int m,n;
int a[maxn];
void dii(int x)
{
  for(int i=1;i<=n;i++)
    dis[i]=INF;
  for(int i=1;i<=n;i++)
    dis[i]=map[x][i];
   vis[x]=1;
  for(int i=2;i<=n;i++)
  {
      int next=0,min=INF;
      for(int j=1;j<=n;j++)
      {
          if(!vis[j]&&min>dis[j])
          {next=j;
          min=dis[j];
          }
      }
      vis[next]=1;
      for(int j=1;j<=n;j++)
      {
          if(!vis[j]&&dis[j]>map[next][j]+dis[next])
            dis[j]=map[next][j]+dis[next];
      }
  }
}
int main()
{
    cin>>n>>m;
    for(int i=1;i<=n;i++)
        for(int j=1;j<=n;j++)
         map[i][j]=INF;
    while(m--)
    {
        int num;
        cin>>num;
        for(int i=0;i<num;i++)
           cin>>a[i];
        for(int i=0;i<num;i++)
            for(int j=i+1;j<num;j++)
             {   if(a[i]!=a[j])
                 map[a[i]][a[j]]=map[a[j]][a[i]]=1;
             }
    }
    double ans=INF;
    for(int i=1;i<=n;i++)
    {
        double sum=0;
        memset(vis,0,sizeof(vis));
        dii(i);
        for(int j=1;j<=n;++j)//记录到其他牛的度数之和
			{
				if(i!=j)
					sum+=dis[j];
			}
			ans=min(ans,sum*1.0/(n-1));
    }
		cout<<((int)(ans*100))<<endl;

    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值