素数环uva524

Problem Description
A ring is compose of n circles as shown in diagram. Put natural number 1, 2, …, n into each circle separately, and the sum of numbers in two adjacent circles should be a prime.

Note: the number of first circle should always be 1.
Input
n (0 < n < 20).

Output
The output format is shown as sample below. Each row represents a series of circle numbers in the ring beginning from 1 clockwisely and anticlockwisely. The order of numbers must satisfy the above requirements. Print solutions in lexicographical order.

You are to write a program that completes above process.

Print a blank line after each case.
Sample Input

6
8

Sample Output

Case 1:
1 4 3 2 5 6
1 6 5 2 3 4

Case 2:
1 2 3 8 5 6 7 4
1 2 5 8 3 4 7 6
1 4 7 6 5 8 3 2
1 6 7 4 3 8 5 2

题意:输入 正整数n,把整数1到n组成一个环,使得相邻两个整数之和均为素数,输出时从整数1开始逆时针排列,n<=16。

思路:使用dfs,每次填数时判断是否符合条件即可。

代码为:

#include<iostream>
#include<cstdio>
#include<string.h>
using  namespace std;
int n,q;
int a[20],b[32]={0,1,0,1,0,1,0,1,0,0,0,1,0,1,0,0,0,1,0,1,0,0,0,1,0,0,0,0,0,1,0,1},c[20];
void dfs(int cur)
{
    if(cur==n&&b[a[0]+a[cur-1]])
    {
        cout<<a[0];    //符合输出条件
        for(int i=1;i<n;i++)
        {
            cout<<" "<<a[i];
        }
        cout<<endl;
    }
    else for(int i=2;i<=n;i++)
    {
        if(!c[i]&&b[i+a[cur-1]])
        {
            a[cur]=i;
            c[i]=1;
            dfs(cur+1);
            a[cur]=0;
            c[i]=0;
        }
    }
}
int main()
{
    q=1;
    while(cin>>n)
    {
        if(q>1)     //控制空行的输出,必须符合,否则错误。
            cout<<endl;
        memset(a,0,sizeof(a));
        memset(c,0,sizeof(c));
        a[0]=1;
        cout<<"Case "<<q++<<":"<<endl;
        dfs(1);
    }
    return 0;
}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值