POJ 1459 :Power Network:最大流算法

Power Network
Time Limit: 2000MS Memory Limit: 32768K
Total Submissions: 23318 Accepted: 12213

Description

A power network consists of nodes (power stations, consumers and dispatchers) connected by power transport lines. A node u may be supplied with an amount s(u) >= 0 of power, may produce an amount 0 <= p(u) <= p max(u) of power, may consume an amount 0 <= c(u) <= min(s(u),c max(u)) of power, and may deliver an amount d(u)=s(u)+p(u)-c(u) of power. The following restrictions apply: c(u)=0 for any power station, p(u)=0 for any consumer, and p(u)=c(u)=0 for any dispatcher. There is at most one power transport line (u,v) from a node u to a node v in the net; it transports an amount 0 <= l(u,v) <= l max(u,v) of power delivered by u to v. Let Con=Σ uc(u) be the power consumed in the net. The problem is to compute the maximum value of Con. 

An example is in figure 1. The label x/y of power station u shows that p(u)=x and p max(u)=y. The label x/y of consumer u shows that c(u)=x and c max(u)=y. The label x/y of power transport line (u,v) shows that l(u,v)=x and l max(u,v)=y. The power consumed is Con=6. Notice that there are other possible states of the network but the value of Con cannot exceed 6. 

Input

There are several data sets in the input. Each data set encodes a power network. It starts with four integers: 0 <= n <= 100 (nodes), 0 <= np <= n (power stations), 0 <= nc <= n (consumers), and 0 <= m <= n^2 (power transport lines). Follow m data triplets (u,v)z, where u and v are node identifiers (starting from 0) and 0 <= z <= 1000 is the value of l max(u,v). Follow np doublets (u)z, where u is the identifier of a power station and 0 <= z <= 10000 is the value of p max(u). The data set ends with nc doublets (u)z, where u is the identifier of a consumer and 0 <= z <= 10000 is the value of c max(u). All input numbers are integers. Except the (u,v)z triplets and the (u)z doublets, which do not contain white spaces, white spaces can occur freely in input. Input data terminate with an end of file and are correct.

Output

For each data set from the input, the program prints on the standard output the maximum amount of power that can be consumed in the corresponding network. Each result has an integral value and is printed from the beginning of a separate line.

Sample Input

2 1 1 2 (0,1)20 (1,0)10 (0)15 (1)20
7 2 3 13 (0,0)1 (0,1)2 (0,2)5 (1,0)1 (1,2)8 (2,3)1 (2,4)7
         (3,5)2 (3,6)5 (4,2)7 (4,3)5 (4,5)1 (6,0)5
         (0)5 (1)2 (3)2 (4)1 (5)4

Sample Output

15
6

Hint

The sample input contains two data sets. The first data set encodes a network with 2 nodes, power station 0 with pmax(0)=15 and consumer 1 with cmax(1)=20, and 2 power transport lines with lmax(0,1)=20 and lmax(1,0)=10. The maximum value of Con is 15. The second data set encodes the network from figure 1.

Source


最大流处女题~~
该题目虽然不是赤裸裸的最大流应用,但是转化非常简单。单独设立源点S和汇点T,由源点S发出单向边指向生产节点,边的容量 是作为边终点的生产者的生产能力P(x);所有的消费者都发出一条边指向汇点T,边的容量是消费者的消费能力C(x)。每个节点指向自身的边可以忽略,因为,自身流向自身没有意义。这样图里面的所有边都转化成中间传输节点,只有源点S和汇点T。问题就转化成了,由源点到汇点的最大流。该题目还有一个变化:由x指向y的边的最大流量和由y指向x的边不一样,也就是说,该图是有向图。那么构建残余图的时候,初始化逆流量不再是0,而是有设定数值,其他完全一样。
通过标准的最大流算法,BFS搜索增广路径,就是传说中的赤裸的SAP算法,一次AC。
#include<stdio.h>
#include<stdlib.h>
#include<string.h>
int n,np,nc,m,sum;
int a[105][105],cai[105][105],use[105],pre[105],tmin;
char tem[10];
void init()
{
	int i,j;
	int x,y,value;
	memset(a,0,sizeof(a));
	memset(cai,0,sizeof(cai));
	memset(use,0,sizeof(use));
	memset(pre,0,sizeof(pre));
	for(i=0;i<m;i++)
	{
		scanf("%s",tem);
		sscanf(tem,"(%d,%d)%d",&x,&y,&value);
		if(x!=y)
		cai[x+1][y+1]=a[x+1][y+1]=value;
	}
	for(i=0;i<np;i++)
	{
		scanf("%s",tem);
		sscanf(tem,"(%d)%d",&x,&value);
		cai[0][x+1]=a[0][x+1]=value;
	}
	for(i=0;i<nc;i++)
	{
		scanf("%s",tem);
		sscanf(tem,"(%d)%d",&x,&value);
		cai[x+1][n+1]=a[x+1][n+1]=value;
	}
    sum=0;
}
int bfs()
{
	int i,j;
	int que[1000],head,end;
	int index;
	head=end=0;
	memset(use,0,sizeof(use));
	memset(pre,0,sizeof(pre));
	que[end++]=0;
	use[0]=1;
	while(head<end)
	{
		index=que[head++];
		if(cai[index][n+1])
		{
			pre[n+1]=index;
			return 1;
		}
		for(i=1;i<=n;i++)
		{
			if(!use[i]&&cai[index]
			[i])
			{
				que[end++]=i;
				use[i]=1;
				pre[i]=index;
			}
		}
	}
	return 0;
}
void update()
{
	int i,j;
	int q,pq;
	q=n+1;
	tmin=10000;
	while(q)
	{
		pq=pre[q];
		if(cai[pq][q]<tmin)
			tmin=cai[pq][q];
		q=pq;
	}
	sum+=tmin;
	q=n+1;
	while(q)
	{
		pq=pre[q];
		cai[pq][q]-=tmin;
		cai[q][pq]+=tmin;
		q=pq;
	}
}
int main()
{
	int i,j;
	while(scanf("%d%d%d%d",&n,&np,&nc,&m)!=EOF)
	{
		init();
		while(bfs())
		{
			update();
		}
		printf("%d\n",sum);
	}
	return 0;
}


深度学习是机器学习的一个子领域,它基于人工神经网络的研究,特别是利用多层次的神经网络来进行学习和模式识别。深度学习模型能够学习数据的高层次特征,这些特征对于图像和语音识别、自然语言处理、医学图像分析等应用至关重要。以下是深度学习的一些关键概念和组成部分: 1. **神经网络(Neural Networks)**:深度学习的基础是人工神经网络,它是由多个层组成的网络结构,包括输入层、隐藏层和输出层。每个层由多个神经元组成,神经元之间通过权重连接。 2. **前馈神经网络(Feedforward Neural Networks)**:这是最常见的神经网络类型,信息从输入层流向隐藏层,最终到达输出层。 3. **卷积神经网络(Convolutional Neural Networks, CNNs)**:这种网络特别适合处理具有网格结构的数据,如图像。它们使用卷积层来提取图像的特征。 4. **循环神经网络(Recurrent Neural Networks, RNNs)**:这种网络能够处理序列数据,如时间序列或自然语言,因为它们具有记忆功能,能够捕捉数据中的时间依赖性。 5. **长短期记忆网络(Long Short-Term Memory, LSTM)**:LSTM 是一种特殊的 RNN,它能够学习长期依赖关系,非常适合复杂的序列预测任务。 6. **生成对抗网络(Generative Adversarial Networks, GANs)**:由两个网络组成,一个生成器和一个判别器,它们相互竞争,生成器生成数据,判别器评估数据的真实性。 7. **深度学习框架**:如 TensorFlow、Keras、PyTorch 等,这些框架提供了构建、训练和部署深度学习模型的工具和库。 8. **激活函数(Activation Functions)**:如 ReLU、Sigmoid、Tanh 等,它们在神经网络中用于添加非线性,使得网络能够学习复杂的函数。 9. **损失函数(Loss Functions)**:用于评估模型的预测与真实值之间的差异,常见的损失函数包括均方误差(MSE)、交叉熵(Cross-Entropy)等。 10. **优化算法(Optimization Algorithms)**:如梯度下降(Gradient Descent)、随机梯度下降(SGD)、Adam 等,用于更新网络权重,以最小化损失函数。 11. **正则化(Regularization)**:技术如 Dropout、L1/L2 正则化等,用于防止模型过拟合。 12. **迁移学习(Transfer Learning)**:利用在一个任务上训练好的模型来提高另一个相关任务的性能。 深度学习在许多领域都取得了显著的成就,但它也面临着一些挑战,如对大量数据的依赖、模型的解释性差、计算资源消耗大等。研究人员正在不断探索新的方法来解决这些问题。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值