hihoCoder 1234 Fractal(精度+数学题+水题)


题目:

This is the logo of PKUACM 2016. More specifically, the logo is generated as follows:

1. Put four points A0(0,0), B0(0,1), C0(1,1), D0(1,0) on a cartesian coordinate system.

2. Link A0B0, B0C0, C0D0, D0A0 separately, forming square A0B0C0D0.

3. Assume we have already generated square AiBiCiDi, then square Ai+1Bi+1Ci+1Di+1 is generated by linking the midpoints of AiBi, BiCi, CiDi and DiAi successively.

4. Repeat step three 1000 times.

Now the designer decides to add a vertical line x=k to this logo( 0<= k < 0.5, and for k, there will be at most 8 digits after the decimal point). He wants to know the number of common points between the new line and the original logo.

输入

In the first line there’s an integer T( T < 10,000), indicating the number of test cases.

Then T lines follow, each describing a test case. Each line contains an float number k, meaning that you should calculate the number of common points between line x = k and the logo.

输出

For each test case, print a line containing one integer indicating the answer. If there are infinity common points, print -1.

样例输入
3
0.375
0.001
0.478
样例输出
-1
4
20

思路: md对此我只想说这辈子再也不想做精度题了..题目写着给出一个float,我就乖乖的写了float然后死活过不去,到处改还是过不去,最后改成double就A了(微笑日狗脸)

#include <iostream>
#include <string.h>
#include <algorithm> 
#include <stdio.h>
#include <math.h>
using namespace std;
double pre[100];

int main(){
	
	
	double a=0.0;
	pre[0]=0;
	int cnt=1;
	for(int i=0;i<=30;i++){
		a+=0.25/pow(2,i);
		pre[cnt++]=a;
	//	printf("%.8f\n",pre[cnt-1]);
	}
	int n;
	cin>>n;
	while(n--){
		double b;
		cin>>b;
		int flag=0;
		int ans=0;
		for(int i=0;i<cnt;i++){	
			if(fabs(b-pre[i])<1e-10){
				flag=1;	
				cout<<"-1"<<endl;
				break;
			}
			if(b>pre[i]){
				ans+=4;
			}		
		}
		if(!flag){
			//cout<<pos<<endl;
			cout<<ans<<endl;
		}
	} 
	return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值