最小生成树 - E - QS Network

E -  QS Network

In the planet w-503 of galaxy cgb, there is a kind of intelligent creature named QS. QScommunicate with each other via networks. If two QS want to get connected, they need to buy two network adapters (one for each QS) and a segment of network cable. Please be advised that ONE NETWORK ADAPTER CAN ONLY BE USED IN A SINGLE CONNECTION.(ie. if a QS want to setup four connections, it needs to buy four adapters). In the procedure of communication, a QS broadcasts its message to all the QS it is connected with, the group of QS who receive the message broadcast the message to all the QS they connected with, the procedure repeats until all the QS's have received the message.
A sample is shown below:


A sample QS network, and QS A want to send a message.

Step 1. QS A sends message to QS B and QS C;

Step 2. QS B sends message to QS A ; QS C sends message to QS A and QS D;

Step 3. the procedure terminates because all the QS received the message.

Each QS has its favorate brand of network adapters and always buys the brand in all of its connections. Also the distance between QS vary. Given the price of each QS's favorate brand of network adapters and the price of cable between each pair of QS, your task is to write a program to determine the minimum cost to setup a QS network.

Input
The 1st line of the input contains an integer t which indicates the number of data sets.

From the second line there are t data sets.

In a single data set,the 1st line contains an interger n which indicates the number of QS.

The 2nd line contains n integers, indicating the price of each QS's favorate network adapter.

In the 3rd line to the n+2th line contain a matrix indicating the price of cable between ecah pair of QS.

Constrains:

all the integers in the input are non-negative and not more than 1000.

Output
for each data set,output the minimum cost in a line. NO extra empty lines needed.

Sample Input
1
3
10 20 30
0 100 200
100 0 300
200 300 0


Sample Output
370

题意:N个结点的最小生成树,点和边都有权值;求最小生成树。

题解:裸prim模板,把实际边权值计算为边权值+两点的点权值即可。

AC代码:

#include<bits/stdc++.h>
using namespace std;
int t,m,n,sum;
const int maxn = 1005;
const int inf = 0x3f3f3f3f;
int a[maxn][maxn];
int vis[maxn];
int length[maxn];
int spend[maxn];
int path[maxn];
void prim()
{
    for(int i=1;i<=n;i++)
    {
        length[i]=a[1][i];
        vis[i]=0;
        path[i]=1;
    }
    for(int i=1;i<=n;i++)
    {
        int mi=inf;
        int u;
        for(int j=1;j<=n;j++)
        {
            if(vis[j]==0&&mi>length[j])
            {
                mi=length[j];
                u=j;
            }
        }
        vis[u]=1;
        sum+=length[u];
        for(int j=1;j<=n;j++)
        {
            if(vis[j]==0&&length[j]>a[u][j])
            {
                length[j]=a[u][j];
                path[j]=u;
            }
        }
       // if(i!=1)sum+=spend[u]+spend[path[u]];

    }
}
int main()
{
    cin>>t;
    while(t--)
    {
        sum=0;
        cin>>n;
        for(int i=1;i<=n;i++)cin>>spend[i];
        for(int i=1;i<=n;i++)
            for(int j=1;j<=n;j++)
            {
                cin>>a[i][j];
                if(i!=j)a[i][j]+=spend[i]+spend[j];
            }
        prim();
        cout<<sum<<endl;
    }
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值