poj 3273 二分法

265 篇文章 1 订阅
15 篇文章 0 订阅

Monthly Expense
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 11446 Accepted: 4688

Description

Farmer John is an astounding accounting wizard and has realized he might run out of money to run the farm. He has already calculated and recorded the exact amount of money (1 ≤moneyi ≤ 10,000) that he will need to spend each day over the nextN (1 ≤ N ≤ 100,000) days.

FJ wants to create a budget for a sequential set of exactly M (1 ≤ MN) fiscal periods called "fajomonths". Each of these fajomonths contains a set of 1 or more consecutive days. Every day is contained in exactly one fajomonth.

FJ's goal is to arrange the fajomonths so as to minimize the expenses of the fajomonth with the highest spending and thus determine his monthly spending limit.

Input

Line 1: Two space-separated integers: N and M
Lines 2.. N+1: Line i+1 contains the number of dollars Farmer John spends on the ith day

Output

Line 1: The smallest possible monthly limit Farmer John can afford to live with.

Sample Input

7 5
100
400
300
100
500
101
400

Sample Output

500

Hint

If Farmer John schedules the months so that the first two days are a month, the third and fourth are a month, and the last three are their own months, he spends at most $500 in any month. Any other method of scheduling gives a larger minimum monthly limit.

Source


老实说这道题开始并没有往2分这个方向想,后来看了网上大牛的攻略之后才发现自己敲的各种弱,先总结一下二分吧。

二分最流行的进入下一轮的方法是l=mid+1; r=mid-1; 当然可以和l=mid 和 r=mid 配合,但是需要有一定前提(见后面代码)。纯使用l=mid 和 r=mid会导致死循环,原因就不多讲了。先贴一个特别2的程序:

#include<iostream>
#include<stdio.h>
#include<string.h>
using namespace std;
int n,m,i,j,sum,l,r,mid,t,tn,Max;
int num[10001];
int main(){
	
	scanf("%d%d",&n,&m);
	sum=0;
	Max=0;
	for(i=0;i<n;i++){
		scanf("%d",&num[i]);
		sum+=num[i];
		Max= (num[i]>Max)?num[i]:Max;
	}
	l=Max;
	r=sum;
	mid=(l+r)/2;


	while(1){
		t=0;
		tn=0;
		for(i=0;i<n;i++){
			t+=num[i];
			if( t>mid ){
				tn++;
				t=num[i];
			}
		}
		if( tn>m ){
			l=mid;
			mid=(l+r)/2;
		}
		else if(tn<=m){
			r=mid;
			mid=(l+r)/2;
		}
		if(l==r)
			break;
	}
	printf("%d\n",mid);
	return 0;
}

这个程序悲催的地方在于:

1. 不能以l==r作为二分退出的条件

2. l=mid;r=mid;

3. 数组居然还小敲了一个0

4. tn少一个++

找上面思路改正后:

#include<iostream>
#include<stdio.h>
#include<string.h>
using namespace std;
int n,m,i,j,sum,l,r,mid,t,tn,Max;
int num[100001];
int main(){
	
	scanf("%d%d",&n,&m);
	sum=0;
	Max=0;
	for(i=0;i<n;i++){
		scanf("%d",&num[i]);
		sum+=num[i];
		Max= (num[i]>Max)?num[i]:Max;
	}
	l=Max;
	r=sum;
	mid=(l+r)/2;


	while(1){
		t=0;
		tn=0;
		mid=(l+r)/2;
		for(i=0;i<n;i++){
			t+=num[i];
			if( t>mid ){
				tn++;
				t=num[i];
			}
		}
		tn++;
		
		if( tn>m )
			l=mid+1;
		else
			r=mid-1;

		if(l>r)
			break;
	}
	printf("%d\n",mid);
	return 0;
}

另外,再贴一个和l=mid 和 r=mid 配合的:

#include<iostream>
#include<string.h>
#include<stdio.h>
using namespace std;
int N=0,M=0,i=0,j=0,sum=0,minv=0,maxv=0,mid=0,t=0,tn=0,Max=0;
int num[100005];
int main(){
	
	scanf("%d%d",&N,&M);
	sum=0;
	Max=0;
	for(i=0;i<N;i++){
		scanf("%d",&num[i]);
		sum+=num[i];
		if(num[i]>Max)
			Max=num[i];
	}
	minv=Max;
	maxv=sum;
	
	while(minv<maxv){
		mid=(minv+maxv)>>1;
		t=0;
		tn=0;
		for(i=0;i<N;i++){
			t+=num[i];
			if( t>mid ){
				t=num[i];
				tn++;
			}
		}
		//tn++;
		/*
		这个当tn>=M时,说明mid肯定不成立(因为tn+1==M时才对),因此可以把minv加快一点;
		*/
        if (tn < M) maxv = mid;
        else minv = mid + 1;
	}
	
	printf("%d\n",minv);
	return 0;
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值