Cube painting

We have a machine for painting cubes. It is supplied with three different colors: blue, red and green. Each face of the cube gets one of these colors. The cube's faces are numbered as in Figure 1.

picture21

Figure 1.

Since a cube has 6 faces, our machine can paint a face-numbered cube in tex2html_wrap_inline126 different ways. When ignoring the face-numbers, the number of different paintings is much less, because a cube can be rotated. See example below. We denote a painted cube by a string of 6 characters, where each character is a br, org. The tex2html_wrap_inline128 character ( tex2html_wrap_inline130 ) from the left gives the color of face i. For example, Figure 2 is a picture of rbgggr and Figure 3 corresponds to rggbgr. Notice that both cubes are painted in the same way: by rotating it around the vertical axis by 90 tex2html_wrap_inline134 , the one changes into the other.

tex2html_wrap138 tex2html_wrap140

Input

The input of your program is a textfile that ends with the standard end-of-file marker. Each line is a string of 12 characters. The first 6 characters of this string are the representation of a painted cube, the remaining 6 characters give you the representation of another cube. Your program determines whether these two cubes are painted in the same way, that is, whether by any combination of rotations one can be turned into the other. (Reflections are not allowed.)

Output

The output is a file of boolean. For each line of input, output contains TRUE if the second half can be obtained from the first half by rotation as describes above, FALSE otherwise.

Sample Input

rbgggrrggbgr
rrrbbbrrbbbr
rbgrbgrrrrrg

Sample Output

TRUE
FALSE
FALSE
自从写了狂斌的搜索专题,感觉这种搜索题都是傻逼题,不知道是不是自己的一种错觉- -,命名方式都已经给了,直接套用比较,然后把上下的面转换,至于中间四个面,只需要顺序转换4次就可以了。
#include<cstdio>
#include<queue>
#include<cstring>
#include<iostream>
#include<string>
#include<algorithm>
using namespace std;
int leap;
char a[20];
string b, c, d;
void dfs()
{
	int i, j;
	char temp;
	d = "";
	d = c;
	for (j = 1; j <= 4; j++){
		d[1] = c[3];
		d[2] = c[1];
		d[3] = c[4];
		d[4] = c[2];
		if (b == d)leap = 1;
		c = d;
	}
}
int main()
{
	int i, j, m, n, ans, t;
	while (scanf("%s", a) != EOF)
	{
		leap = 0;
		b = "";
		for (i = 6; i < 12; i++)
			b += a[i];
		c = "";
		for (i = 0; i < 6; i++)
			c += a[i];
		dfs();
		c[0] = a[1]; c[1] = a[5]; c[2] = a[2]; c[3] = a[3]; c[4] = a[0]; c[5] = a[4];
		dfs();
		c[0] = a[2]; c[1] = a[5]; c[2] = a[4]; c[3] = a[1]; c[4] = a[0]; c[5] = a[3];
		dfs();
		c[0] = a[3]; c[1] = a[5]; c[2] = a[1]; c[3] = a[4]; c[4] = a[0]; c[5] = a[2];
		dfs();
		c[0] = a[4]; c[1] = a[0]; c[2] = a[2]; c[3] = a[3]; c[4] = a[5]; c[5] = a[1];
		dfs();
		c[0] = a[5]; c[1] = a[4]; c[2] = a[2]; c[3] = a[3]; c[4] = a[1]; c[5] = a[0];
		dfs();
		if (leap)cout << "TRUE" << endl;
		else cout << "FALSE" << endl;
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值