poj 2785 4 Values whose Sum is 0

原题:
4 Values whose Sum is 0
Time Limit: 15000MS Memory Limit: 228000K
Total Submissions: 18834 Accepted: 5600
Case Time Limit: 5000MS
Description

The SUM problem can be formulated as follows: given four lists A, B, C, D of integer values, compute how many quadruplet (a, b, c, d ) ∈ A x B x C x D are such that a + b + c + d = 0 . In the following, we assume that all lists have the same size n .
Input

The first line of the input file contains the size of the lists n (this value can be as large as 4000). We then have n lines containing four integer values (with absolute value as large as 228 ) that belong respectively to A, B, C and D .
Output

For each input file, your program has to write the number quadruplets whose sum is zero.
Sample Input

6
-45 22 42 -16
-41 -27 56 30
-36 53 -37 77
-36 30 -75 -46
26 -38 -10 62
-32 -54 -6 45
Sample Output

5
Hint

Sample Explanation: Indeed, the sum of the five following quadruplets is zero: (-45, -27, 42, 30), (26, 30, -10, -46), (-32, 22, 56, -46),(-32, 30, -75, 77), (-32, -54, 56, 30).
Source

Southwestern Europe 2005
大意:
给你一个数6,然后给你4个数组A,B,C,D。每个数组里面6个数,现在让你找出分别在A,B,C,D中各找一个数使得和为0。输出方案数。

//#include <bits/stdc++.h>
#include<iostream>
#include<algorithm>
#include<vector>
using namespace std;
//fstream in,out;
vector<int> A,B,C,D,s;
int n;
int main()
{
    ios::sync_with_stdio(false);
    int a,b,c,d;
    while(cin>>n)
    {
        A.clear();
        B.clear();
        C.clear();
        D.clear();
        s.clear();
        for(int i=0;i<n;i++)
        {
            cin>>a>>b>>c>>d;
            A.push_back(a);
            B.push_back(b);
            C.push_back(c);
            D.push_back(d);
        }

        for(int i=0;i<n;i++)
            for(int j=0;j<n;j++)
                s.push_back(C[i]+D[j]);

        sort(s.begin(),s.end());
        long long ans=0;
        for(int i=0;i<n;i++)
        {
            for(int j=0;j<n;j++)
            {
                int tmp=A[i]+B[j];
                ans+=upper_bound(s.begin(),s.end(),-tmp)-lower_bound(s.begin(),s.end(),-tmp);
            }
        }
        cout<<ans<<endl;
    }
    return 0;
}

解答:
在挑战程序设计竞赛上面看到的,很基础的二分查找题目。把C[i]和D[j]的和存储在s当中。然后对s排序,枚举a[i]+b[j],然后二分查找s当中满足-(a[i]+b[j])的上下界即可

看讨论区此题还有hash做法,争取稍后补上

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值