uva 11991 Easy Problem from Rujia Liu?

原题:
Given an array, your task is to find the k-th occurrence (from left to right) of an integer v. To make the problem more difficult (and interesting!), you’ll have to answer m such queries.
Input
There are several test cases. The first line of each test case contains two integers n, m (1 ≤ n,m ≤ 100,000), the number of elements in the array, and the number of queries. The next line contains n positive integers not larger than 1,000,000. Each of the following m lines contains two integer k and v (1 ≤ k ≤ n, 1 ≤ v ≤ 1,000,000). The input is terminated by end-of-file (EOF).
Output
For each query, print the 1-based location of the occurrence. If there is no such element, output ‘0’instead.
Sample Input
8 4
1 3 2 2 4 3 2 1
1 3
2 4
3 2
4 2
Sample Output
2
0
7
0

中文:
给你n个数,然后给你m个查询,每个查询包含两个数k和v问你第k个v的小标是多少?

#include <bits/stdc++.h>
using namespace std;
unordered_map<int,vector<int>> miv;
int n,m;
int main()
{
    ios::sync_with_stdio(false);
    while(cin>>n>>m)
    {
        miv.clear();
        for(int i=1;i<=n;i++)
        {
            int res;
            cin>>res;
            miv[res].push_back(i);
        }
        for(int i=1;i<=m;i++)
        {
            int k,v;
            cin>>k>>v;
            if(miv.find(v)==miv.end()||miv[v].size()<k)
                cout<<0<<endl;
            else
            {
                cout<<miv[v][k-1]<<endl;
            }
        }
    }
    return 0;
}

思路:
这题的名起的,不秒杀都不好意思~~
思路见下面的图
这里写图片描述
长方格里面的数是输入的所有数,每个方格里面的数下面的链是按顺序存储的下标值。

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值