【PAT】1024.Palindromic Number (25)

题目描述

A number that will be the same when it is written forwards or backwards is known as a Palindromic Number. For example, 1234321 is a palindromic number. All single digit numbers are palindromic numbers.

Non-palindromic numbers can be paired with palindromic ones via a series of operations. First, the non-palindromic number is reversed and the result is added to the original number. If the result is not a palindromic number, this is repeated until it gives a palindromic number. For example, if we start from 67, we can obtain a palindromic number in 2 steps: 67 + 76 = 143, and 143 + 341 = 484.

Given any positive integer N, you are supposed to find its paired palindromic number and the number of steps taken to find it.

翻译:一个数字如果反序和正序相同,则称作回文数。举个例子,1234321是一个回文数。所有的一位数都是回文数。
非回文数可以通过一系列变换转变成回文数。第一步,将非回文数翻转然后将结果加到上面。如果还不是回文数,则重复此操作直到它是一个回文数。举个例子,如果我们从67开始,我们可以通过以下两步转换为回文数:67 + 76 = 143, 143 + 341 = 484。

INPUT FORMAT

Each input file contains one test case. Each case consists of two positive numbers N and K, where N (<= 1010) is the initial numer and K (<= 100) is the maximum number of steps. The numbers are separated by a space.

翻译:一个输入文件包括一组测试数据。每组测试数据包括两个正整数N和K,N(<= 10^10)是初始数,K(<= 100)是最大步数。数字之间用空格隔开。

OUTPUT FORMAT

For each test case, output two numbers, one in each line. The first number is the paired palindromic number of N, and the second number is the number of steps taken to find the palindromic number. If the palindromic number is not found after K steps, just output the number obtained at the Kth step and K instead.

翻译:对于每组输入数据,输出两个数字,一个一行。第一个数字是得到的回文数N,第二个数字是得到回文数的步数。如果知道K次结束都没有发现回文数,就输出K步后的数字和K次变换。


Sample Input 1:

67 3

Sample Output 1:

484
2


Sample Input 2:

69 3

Sample Output 2:

1353
3


解题思路

跟上题做法一样,用字符数组保存数据,再转化为数字数组,注意倒序保存,不然进位会出错。然后倒序相加,如果回文就退出,否则进行K次重复变换。

#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
#include<string>
#include<algorithm>
#define INF 99999999
using namespace std;
int length,a[110],b[110],K;
char s[15];
void Copy(){
    for(int i=0;i<length;i++){
        b[i]=a[length-1-i];
    }
}
void print(){
    for(int i=0;i<length;i++)
    printf("%d",a[length-1-i]);
    printf("\n");
}
void Plus(){
    for(int i=0;i<length;i++){
        a[i]+=b[i];
        if(a[i]>=10){
            a[i+1]++;
            a[i]%=10;
        } 
    }
    if(a[length])length++;
}
int Judge(){
    for(int i=0;i<length/2;i++){
        if(a[i]!=a[length-1-i])return 0;
    }
    return 1;
}
int main(){
    scanf("%s%d",s,&K);
    length=strlen(s);
    for(int i=0;i<length;i++)a[i]=s[i]-'0';
    int k=K;
    while(k){
        if(Judge())break;
        Copy();
        Plus();
        k--;
    } 
    print();
    printf("%d\n",K-k);
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值