【PAT】1032. Sharing (25)

题目描述

To store English words, one method is to use linked lists and store a word letter by letter. To save some space, we may let the words share the same sublist if they share the same suffix. For example, “loading” and “being” are stored as showed in Figure 1.
PAT官网甲级练习1032题目图片

You are supposed to find the starting position of the common suffix (e.g. the position of “i” in Figure 1).

翻译:为了存储英文单词,一个方法是用链表将单词的字母一个一个保存起来。为了节省一些空间,我们可能让有相同后缀的单词共享同样的子表。例如,“loading”和“being”将以图一所示格式存储。
你需要找出公共后缀的起始位置(例如图一中“i”的位置)。

INPUT FORMAT

Each input file contains one test case. For each case, the first line contains two addresses of nodes and a positive N (<= 105), where the two addresses are the addresses of the first nodes of the two words, and N is the total number of nodes. The address of a node is a 5-digit positive integer, and NULL is represented by -1.

Then N lines follow, each describes a node in the format:

Address Data Next

where Address is the position of the node, Data is the letter contained by this node which is an English letter chosen from {a-z, A-Z}, and Next is the position of the next node.

翻译:每个输入文件包括一组测试数据。对于每组输入数据,第一行包括两个单词的起始节点的地址和一个正整数N (<= 105)-总节点数。节点地址为一个5位正整数,-1代表NULL。

OUTPUT FORMAT

For each case, simply output the 5-digit starting position of the common suffix. If the two words have no common suffix, output “-1” instead.

翻译:对于每组输入数据,输出公共后缀的5位起始地址。如果两个单词没有公共后缀,就输出“-1”。


Sample Input 1:

11111 22222 9
67890 i 00002
00010 a 12345
00003 g -1
12345 D 67890
00002 n 00003
22222 B 23456
11111 L 00001
23456 e 67890
00001 o 00010

Sample Output 1:

67890


Sample Input 2:

00001 00002 4
00001 a 10001
10001 s -1
00002 a 10002
10002 t -1

Sample Output 2:

1


解题思路

保存两个字符串编号数组,然后从后往前比较,不相等就退出循环输出。

#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
#include<string>
#include<algorithm>
#define INF 99999999
using namespace std;
struct Node{
    char ch;
    int to;
}node[100000];
int s1,s2,N;
int d1[100010],l1=0,d2[100010],l2=0; 
int main(){
    scanf("%d%d%d",&s1,&s2,&N);
    int a,c;
    char b;
    for(int i=0;i<N;i++){
        scanf("%d %c %d",&a,&b,&c);
        node[a].ch=b;
        node[a].to=c;
    }
    while(s1>=0){
        d1[l1++]=s1;
        s1=node[s1].to;
    }
    while(s2>=0){
        d2[l2++]=s2;
        s2=node[s2].to;
    }
    int pre=0;
    for(int i=0;i<l1;i++){
        if(d1[l1-1-i]!=d2[l2-1-i])break;
        pre=d1[l1-1-i];
    }
    if(pre==0)printf("-1\n");
    else printf("%05d\n",pre);
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值