【PAT】1042. Shuffling Machine (20)

题目描述

Shuffling is a procedure used to randomize a deck of playing cards. Because standard shuffling techniques are seen as weak, and in order to avoid “inside jobs” where employees collaborate with gamblers by performing inadequate shuffles, many casinos employ automatic shuffling machines. Your task is to simulate a shuffling machine.

The machine shuffles a deck of 54 cards according to a given random order and repeats for a given number of times. It is assumed that the initial status of a card deck is in the following order:

S1, S2, …, S13, H1, H2, …, H13, C1, C2, …, C13, D1, D2, …, D13, J1, J2

where “S” stands for “Spade”, “H” for “Heart”, “C” for “Club”, “D” for “Diamond”, and “J” for “Joker”. A given order is a permutation of distinct integers in [1, 54]. If the number at the i-th position is j, it means to move the card from position i to position j. For example, suppose we only have 5 cards: S3, H5, C1, D13 and J2. Given a shuffling order {4, 2, 5, 3, 1}, the result will be: J2, H5, D13, S3, C1. If we are to repeat the shuffling again, the result will be: C1, H5, S3, J2, D13.

翻译:洗牌是一个在牌桌上随机生成(序列)的过程。因为标准的洗牌技巧看起来很弱,并且为了避免“黑幕”即员工和赌徒合作进行不充分的洗牌,许多赌场雇佣了自动洗牌机。你的任务就是模拟一台洗牌机。
洗牌机根据一个给定的随机序列进行洗牌,并且重复给定次数。假设一个牌桌初始的序列为:
S1, S2, …, S13, H1, H2, …, H13, C1, C2, …, C13, D1, D2, …, D13, J1, J2
“S”代表黑桃,“H”代表红心,“C”代表梅花,“D”代表方块,“J”代表王。给定的序列是在[1-54]中的唯一数字组成的序列。如果在第i位的数字是j,则代表将卡片从i移到j。举个例子,假设我们只有5张卡:S3, H5, C1, D13和J2。给定一个洗牌顺序 {4, 2, 5, 3, 1}, 洗牌结果将为: J2, H5, D13, S3, C1。如果我们重复该洗牌过程,结果将为:C1, H5, S3, J2, D13。

INPUT FOMRAT

Each input file contains one test case. For each case, the first line contains a positive integer K (<= 20) which is the number of repeat times. Then the next line contains the given order. All the numbers in a line are separated by a space.

翻译:每个输入文件包含一组测试数据。对于每组输入数据,第一行包括一个正整数K (<= 20)代表重复的次数。接着一行包括给定的顺序。所有的数字之间用空格隔开。

OUTPUT FOMRAT

For each test case, print the shuffling results in one line. All the cards are separated by a space, and there must be no extra space at the end of the line.

翻译:对于每组输入数据,输出一行洗牌的结果。所有的卡片之间用空格隔开,并且末尾不能有空格。


Sample Input:

2
36 52 37 38 3 39 40 53 54 41 11 12 13 42 43 44 2 4 23 24 25 26 27 6 7 8 48 49 50 51 9 10 14 15 16 5 17 18 19 1 20 21 22 28 29 30 31 32 33 34 35 45 46 47

Sample Output:

S7 C11 C10 C12 S1 H7 H8 H9 D8 D9 S11 S12 S13 D10 D11 D12 S3 S4 S6 S10 H1 H2 C13 D2 D3 D4 H6 H3 D13 J1 J2 C1 C2 C3 C4 D1 S5 H5 H11 H12 C6 C7 C8 C9 S2 S8 S9 H10 D5 D6 D7 H4 H13 C5


解题思路

定义一个结构体保存卡片,然后不断根据给出的顺序改变数组即可。

#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
#include<string>
#include<algorithm>
#define INF 99999999
using namespace std;
struct card{
    char c;int num;
    void print(){
        printf("%c%d",c,num);
    }
};
card s[55];
card temp[55];
int N,Order[55];
void init(){
    for(int i=1;i<=54;i++){
        if(i<=13)s[i].c='S';
        else if(i>13&&i<=26)s[i].c='H';
        else if(i>26&&i<=39)s[i].c='C';
        else if(i>39&&i<=52)s[i].c='D';
        else s[i].c='J';
        s[i].num=i%13==0?13:i%13;
    }   
}
void fun(){
    for(int i=1;i<=54;i++)temp[Order[i]]=s[i];
    for(int i=1;i<=54;i++)s[i]=temp[i];
}
void Print(){
    for(int i=1;i<=54;i++){
        if(i!=1)printf(" ");
        s[i].print();
    }
    printf("\n");   
}
int main(){
    scanf("%d",&N);
    for(int i=1;i<=54;i++)
    scanf("%d",&Order[i]);
    init();
    for(int i=0;i<N;i++)fun();
    Print();
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
大学生就业服务平台管理系统按照操作主体分为管理员和用户。管理员的功能包括学生档案管理、字典管理、试卷管理、试卷选题管理、试题表管理、考试记录表管理、答题详情表管理、错题表管理、法律法规管理、法律法规收藏管理、法律法规留言管理、就业分析管理、论坛管理、企业管理、简历管理、老师管理、简历投递管理、新闻资讯管理、新闻资讯收藏管理、新闻资讯留言管理、学生信息管理、宣传管理、学生管理、职位招聘管理、职位收藏管理、招聘咨询管理、管理员管理。用户的功能等。该系统采用了Mysql数据库,Java语言,Spring Boot框架等技术进行编程实现。 大学生就业服务平台管理系统可以提高大学生就业服务平台信息管理问题的解决效率,优化大学生就业服务平台信息处理流程,保证大学生就业服务平台信息数据的安全,它是一个非常可靠,非常安全的应用程序。 管理员权限操作的功能包括管理新闻信息,管理大学生就业服务平台信息,包括考试管理,培训管理,投递管理,薪资管理等,可以管理新闻信息。 考试管理界面,管理员在考试管理界面中可以对界面中显示,可以对考试信息的考试状态进行查看,可以添加新的考试信息等。投递管理界面,管理员在投递管理界面中查看投递种类信息,投递描述信息,新增投递信息等。新闻信息管理界面,管理员在新闻信息管理界面中新增新闻信息,可以删除新闻信息。新闻信息类型管理界面,管理员在新闻信息类型管理界面查看新闻信息的工作状态,可以对新闻信息的数据进行导出,可以添加新新闻信息的信息,可以编辑新闻信息信息,删除新闻信息信息。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值