【PAT】1046. Shortest Distance (20)

题目描述

The task is really simple: given N exits on a highway which forms a simple cycle, you are supposed to tell the shortest distance between any pair of exits.

翻译:这次的任务真的很简单:给你一条一个圆形高速公路上的N个出口,你需要说出任意一对出口之间的最短距离。

INPUT FORMAT

Each input file contains one test case. For each case, the first line contains an integer N (in [3, 105]), followed by N integer distances D1 D2 … DN, where Di is the distance between the i-th and the (i+1)-st exits, and DN is between the N-th and the 1st exits. All the numbers in a line are separated by a space. The second line gives a positive integer M (<=104), with M lines follow, each contains a pair of exit numbers, provided that the exits are numbered from 1 to N. It is guaranteed that the total round trip distance is no more than 107.

翻译:每个输入文件包含一组测试数据。对于每组输入数据,第一行包括一个正整数N(3-10^5),接着N个正整数为距离D1 D2 … DN, Di代表第i个出口和第i+1个出口之间的距离,DN为第N个出口与第一个出口之间的距离。一行内所有数字用空格隔开。第二行是一个正整数M(<=10^4),跟着M行,每行包括一对出口编号, 假设出口被编号为1—N。数据保证圆形路径的距离总和不超过10^7。

OUTPUT FORMAT

For each test case, print your results in M lines, each contains the shortest distance between the corresponding given pair of exits.

翻译:对于每组输入数据,输出M行你的答案,每一行包括给出的一对对应的出口之间的最短距离。


Sample Input:

5 1 2 4 14 9
3
1 3
2 5
4 1

Sample Output:

3
10
7


解题思路

用sum数组保存出口之间的距离,然后取min(sum[i-1]-sum[j-1],sum[N]-(sum[i-1]-sum[j-1]))(即两个出口之间从小到大的距离和从大到小的距离)即可。

#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
#include<string>
#include<vector>
#include<algorithm>
#define INF 99999999
using namespace std;
int N,sum[100010],M;
int main(){
    scanf("%d",&N);
    int a;
    for(int i=1;i<=N;i++){
        scanf("%d",&a);
        sum[i]=sum[i-1]+a;
    }
    scanf("%d",&M);
    int pre,pro;
    for(int i=0;i<M;i++){
        scanf("%d%d",&pre,&pro);
        int temp=abs(sum[pro-1]-sum[pre-1]);
        printf("%d\n",min(temp,sum[N]-temp));
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值