【PAT】1049. Counting Ones (30)

解题思路

The task is simple: given any positive integer N, you are supposed to count the total number of 1’s in the decimal form of the integers from 1 to N. For example, given N being 12, there are five 1’s in 1, 10, 11, and 12.

翻译:这次任务很简单:给你任意一个正整数N,你需要输出从1到N的数列的十进制格式中数字1的个数。举个例子,给你N为12,共有5个‘1’分别在1, 10, 11和12里。

INPUT FORMAT

Each input file contains one test case which gives the positive N (<=230).

翻译:每个输入文件包含一组测试数据,为一个正整数N(<=2^30).

OUTPUT FORMAT

For each test case, print the number of 1’s in one line.

翻译:对于每组输入数据,输出一行数字1个个数。


Sample Input:

12

Sample Output:

5


解题思路

这题算了好久都没写出来,最后还是看了算法笔记。。。

#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
#include<string>
#include<algorithm>
#define INF 99999999
using namespace std;
int N;
int main(){
    scanf("%d",&N);
    int sum=0,pow=1;
    while(N/pow){
        int left=N/(pow*10);
        int now=N/pow%10;
        int right=N%pow;
        if(now==0)sum+=left*pow;
        else if(now==1)sum+=left*pow+right+1;
        else    sum+=(left+1)*pow;
        pow*=10;
    }
    printf("%d\n",sum);
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值