【PAT】1070. Mooncake (25)【贪心算法】

题目描述

Mooncake is a Chinese bakery product traditionally eaten during the Mid-Autumn Festival. Many types of fillings and crusts can be found in traditional mooncakes according to the region’s culture. Now given the inventory amounts and the prices of all kinds of the mooncakes, together with the maximum total demand of the market, you are supposed to tell the maximum profit that can be made.

Note: partial inventory storage can be taken. The sample shows the following situation: given three kinds of mooncakes with inventory amounts being 180, 150, and 100 thousand tons, and the prices being 7.5, 7.2, and 4.5 billion yuans. If the market demand can be at most 200 thousand tons, the best we can do is to sell 150 thousand tons of the second kind of mooncake, and 50 thousand tons of the third kind. Hence the total profit is 7.2 + 4.5/2 = 9.45 (billion yuans).

翻译:月饼是一种中国传统烘烤食品,一般在中秋节期间食用。根据各地文化,你可以找到许多种类的馅和面皮。现在给你存货数量和所有种类的月饼的价格,和市场需求的最大数量,你需要说出最大的利润。

INPUT FOMRAT

Each input file contains one test case. For each case, the first line contains 2 positive integers N (<=1000), the number of different kinds of mooncakes, and D (<=500 thousand tons), the maximum total demand of the market. Then the second line gives the positive inventory amounts (in thousand tons), and the third line gives the positive prices (in billion yuans) of N kinds of mooncakes. All the numbers in a line are separated by a space.

翻译:每个输入文件包含一组测试数据。对于每组输入数据,第一行包括2个正整数N(<=1000),代表不同种类月饼的数量,和D(<=500千吨),市场需求的最大数量。接着第二行给出每种月饼的库存(千吨),第三行给出这N种月饼的价格。所有数字之间用空格隔开。

OUTPUT FORMAT

For each test case, print the maximum profit (in billion yuans) in one line, accurate up to 2 decimal places.

翻译:对于每组输入数据,输出一行最大的收益(亿元),保留两位小数。


Sample Input:

3 200
180 150 100
7.5 7.2 4.5

Sample Output:

9.45


解题思路

通过贪心算法,每次取单价最高的月饼,直到队列为空或总量到达D。注意数值最好全用double保存,否则可能会报错。

#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
#include<string>
#include<queue>
#include<algorithm>
#define INF 99999999
using namespace std;
struct Mooncake{
    double D;
    double price;
    Mooncake(double d,double p):D(d),price(p){}
    bool operator<(const Mooncake &a)const{
        double weigh=price/D;
        double weigh1=a.price/a.D; 
        return weigh<weigh1;
    }
}; 
priority_queue<Mooncake> q;
double N,D;
double d[1010];
double p[1010];
int main(){
    scanf("%lf%lf",&N,&D);
    for(int i=0;i<N;i++)scanf("%lf",&d[i]);
    for(int i=0;i<N;i++){
        scanf("%lf",&p[i]);
        q.push(Mooncake(d[i],p[i]));
    }
    double sum=0;
    double price=0.0;
    while(!q.empty()&&sum<D){
        Mooncake temp=q.top();q.pop();
        int amount=min(temp.D,D-sum);
        price+=temp.price*amount*1.0/temp.D;
        sum+=amount;
    }
    printf("%.2lf",price);
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
import java.io.BufferedReader; import java.io.IOException; import java.io.InputStreamReader; import java.util.ArrayList; import java.util.Arrays; import java.util.Collection; import java.util.Collections; import java.util.LinkedList; import java.util.List; import java.util.Scanner; public class Main{ public static void main(String[] args) throws IOException { BufferedReader in=new BufferedReader(new InputStreamReader(System.in)); int n; double need; double sum=0; String s[]=in.readLine().split(" "); n=Integer.parseInt(s[0]); need=Double.parseDouble(s[1]); String amount[]=in.readLine().split(" "); String price[]=in.readLine().split(" "); ArrayList<Mooncake> cakes=new ArrayList<Mooncake>(); for(int i=0;i<n;i++){ Mooncake cake=new Mooncake(); cake.setAmount(Double.parseDouble(amount[i])); cake.setSales(Double.parseDouble(price[i])); cake.setValues(Double.parseDouble(price[i])/Double.parseDouble(amount[i])); cakes.add(cake); } Collections.sort(cakes); for(Mooncake c: cakes){ if(need>=c.amount){ need=need-c.amount; sum+=c.amount*c.values; } else{ sum+=need*c.values; need=0; } if(need==0){ break; } } System.out.printf("%.2f",sum); } static class Mooncake implements Comparable<Mooncake>{ double amount; double sales; double values; public double getAmount() { return amount; } public void setAmount(double amount) { this.amount = amount; } public double getSales() { return sales; } public void setSales(double sales) { this.sales = sales; } public double getValues() { return values; } public void setValues(double values) { this.values = values; } @Override public int compareTo(Mooncake arg0) { // TODO Auto-generated method stub return this.values>arg0.values?-1:1; } } }转c++
05-23
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值