【PAT】1125. Chain the Ropes (25)【Priority_Queue使用】

题目描述

Given some segments of rope, you are supposed to chain them into one rope. Each time you may only fold two segments into loops and chain them into one piece, as shown by the figure. The resulting chain will be treated as another segment of rope and can be folded again. After each chaining, the lengths of the original two segments will be halved.

rope.jpg

Your job is to make the longest possible rope out of N given segments.

翻译:给定几段绳子,你需要把它们串成一根绳子。如图所示,每次只能将两段折叠成环,并将它们链成一段。产生的链将被视为另一段绳子,可以再次折叠。每次链接之后,原始两段绳子的长度将减半。
你的任务是使用N根给定的绳子制作出最长的绳子。

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (2≤N≤10​4). Then N positive integer lengths of the segments are given in the next line, separated by spaces. All the integers are no more than 104.

翻译:每个输入文件包含一组测试数据。对于每组测试数据,第一行给出一个正整数N (2≤N≤10​4)。接着一行给出N个正整数表示每段绳子的的长度,用空格隔开。所有整数大小不超过104

Output Specification:

For each case, print in a line the length of the longest possible rope that can be made by the given segments. The result must be rounded to the nearest integer that is no greater than the maximum length.

翻译:对于每组测试数据,输出一行通过给定绳子可以得到的最长的绳子的长度。结果必须被保留为不超过最大长度的最近整数(向下取整)。


Sample Input:

8
10 15 12 3 4 13 1 15


Sample Output:

14


解题思路

使用优先队列来做比较简单,每次选取最短的两根绳子进行折叠,将得到的结果再插入队列。

#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
#include<string>
#include<queue>
#include<algorithm>
#define INF 99999999
using namespace std;
priority_queue<double,vector<double>,greater<double> > q;//从小到大排序 
int N;
int main(){
	scanf("%d",&N);
	int a;
	for(int i=0;i<N;i++){
		scanf("%d",&a);
		q.push(a);
	}
	while(q.size()>1){
		double temp1=q.top();q.pop();
		double temp2=q.top();q.pop();
		double temp=(temp1+temp2)/2.0;
		q.push(temp);
	}
	double temp=q.top();q.pop();
	printf("%d\n",(int)temp);
	return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值