【PAT】1134.Vertex Cover (25)【模拟】

题目描述

A vertex cover of a graph is a set of vertices such that each edge of the graph is incident to at least one vertex of the set. Now given a graph with several vertex sets, you are supposed to tell if each of them is a vertex cover or not.

翻译:一个顶点覆盖是一组顶点,使得图的每条边都至少有一个顶点存在于该集合中。现在给定一个图与几个顶点集,你需要依次说出它们是否是一个顶点覆盖。

Input Specification:

Each input file contains one test case. For each case, the first line gives two positive integers N and M (both no more than 10​4​​ ), being the total numbers of vertices and the edges, respectively. Then M lines follow, each describes an edge by giving the indices (from 0 to N−1) of the two ends of the edge.

After the graph, a positive integer K (≤ 100) is given, which is the number of queries. Then K lines of queries follow, each in the format:

N​v v[1] v[2]⋯v[Nv]
where Nv is the number of vertices in the set, and v[i]'s are the indices of the vertices.

翻译:每个输入文件包含一组测试数据。对于每组测试数据,第一行给出两个正整数N和M(都不超过10​4​​),分别表示节点总数和边的总条数。接下来M行每一行通过给出一条边的两个顶点编号(从0到N-1)来描述一条边。
在图后面,给出一个正整数K (≤ 100),表示查询个数。接下来K行查询,每一行按照以下格式:

N​v v[1] v[2]⋯v[Nv]
Nv表示该顶点集的顶点数,v[i]为顶点的编号。

Output Specification:

For each query, print in a line Yes if the set is a vertex cover, or No if not.

翻译:对于每个查询,如果是点覆盖集则输出一行Yes否则输出No。


Sample Input:

10 11
8 7
6 8
4 5
8 4
8 1
1 2
1 4
9 8
9 1
1 0
2 4
5
4 0 3 8 4
6 6 1 7 5 4 9
3 1 8 4
2 2 8
7 9 8 7 6 5 4 2


Sample Output:

No
Yes
Yes
No
No


解题思路

先用Hash表记录顶点集,然后依次判断每条边是否有一个顶点在顶点集中,如果没有直接跳出循环并输出No。注意每次都要重置Hash表。

#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
#include<string>
#include<vector>
#include<algorithm>
#define INF 99999999
#define bug puts("Hello\n")
using namespace std;
int Hash[10010];
int Edge[10010][2];
int N,M,K; 
int main(){
	scanf("%d%d",&N,&M); 
	for(int i=0;i<M;i++){
		scanf("%d%d",&Edge[i][0],&Edge[i][1]);
	}
	scanf("%d",&K);
	int Nv;
	for(int k=0;k<K;k++){
		scanf("%d",&Nv);
		int tmp;
		memset(Hash,0,sizeof(Hash));
		for(int i=0;i<Nv;i++){
			scanf("%d",&tmp);
			Hash[tmp]=1;
		}
		int i;
		for(i=0;i<M;i++){
			if(Hash[Edge[i][0]]||Hash[Edge[i][1]]);
			else break;
		}
		if(i==M)printf("Yes\n");
		else printf("No\n");
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值