POJ1564(DFS构造法) Sum It Up

Sum It Up
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 5378 Accepted: 2714

Description

Given a specified total t and a list of n integers, find all distinct sums using numbers from the list that add up to t. For example, if t = 4, n = 6, and the list is [4, 3, 2, 2, 1, 1], then there are four different sums that equal 4: 4, 3+1, 2+2, and 2+1+1. (A number can be used within a sum as many times as it appears in the list, and a single number counts as a sum.) Your job is to solve this problem in general.

Input

The input will contain one or more test cases, one per line. Each test case contains t, the total, followed by n, the number of integers in the list, followed by n integers x 1 , . . . , x n . If n = 0 it signals the end of the input; otherwise, t will be a positive integer less than 1000, n will be an integer between 1 and 12 (inclusive), and x 1 , . . . , x n will be positive integers less than 100. All numbers will be separated by exactly one space. The numbers in each list appear in nonincreasing order, and there may be repetitions.

Output

For each test case, first output a line containing `Sums of', the total, and a colon. Then output each sum, one per line; if there are no sums, output the line `NONE'. The numbers within each sum must appear in nonincreasing order. A number may be repeated in the sum as many times as it was repeated in the original list. The sums themselves must be sorted in decreasing order based on the numbers appearing in the sum. In other words, the sums must be sorted by their first number; sums with the same first number must be sorted by their second number; sums with the same first two numbers must be sorted by their third number; and so on. Within each test case, all sums must be distinct; the same sum cannot appear twice.

Sample Input

4 6 4 3 2 2 1 1
5 3 2 1 1
400 12 50 50 50 50 50 50 25 25 25 25 25 25
0 0

Sample Output

Sums of 4:
4
3+1
2+2
2+1+1
Sums of 5:
NONE
Sums of 400:
50+50+50+50+50+50+25+25+25+25
50+50+50+50+50+25+25+25+25+25+25

题目大意:定和选数:给定n个数,要求选出若干个相加得到t,输出所有方案

 
 
这是一个组合搜索问题,要求计算所有合法组合,目标节点遍布搜索树,可用DFS求解,采用DFS构造法。 一开始从sum开始,逐渐减少,知道sum=0为止,注意重复的时候就不要再继续DFS(就是减枝)。
#include <iostream>
#include <cstdio>
#include <cstring>
#include <cmath>
#include <ctime>
#include <queue>
#include <stack>
#include <vector>
#include <algorithm>
#include <string>
using namespace std;
#define forl(i,a,b)  for(int i=(a);i<(b);++i)
#define forle(i,a,b) for(int i=(a);i<=(b);++i)
#define forg(i,a,b)  for(int i=(a);i>(b);--i)
#define forge(i,a,b) for(int i=(a);i>=(b);--i)
#define mes(a,v)  memset(a, v, sizeof (a) );
#define cpy(a,b)  memcpy(a, b, sizeof (a) );
#define mesn(a, v, n) memset(a, v, (n)*sizeof((a)[0]))
#define cpyn(a, b, n) memcpy(a, v, (n)*sizeof((a)[0]))
int a[200],n,m,sum;
int cnt,ans[200],is_ok;
void Dfs(int sum,int pos,int cnt)
{
    if(sum==0)
    {
        is_ok=1;
        for(int i=0;i<cnt;i++)      //满足结果就输出
        {
            if(i==0)     printf("%d",ans[i]);
            else    printf("+%d",ans[i]);
        }
        printf("\n");
        return;
    }
    for(int i=pos;i<m;i++)           //掌握这个方法,领悟这个地方就,完成这道题的目标了
    {
        if(i==pos||a[i]!=a[i-1])
        {
            ans[cnt]=a[i];
            Dfs(sum-a[i],i+1,cnt+1);
        }
    }
}
int main()
{
    //freopen("in.txt","r",stdin);
    while(scanf("%d%d",&n,&m)!=EOF&&n!=0)
    {
        memset(a,0,sizeof(a));
        for(int i=0;i<m;i++)
            scanf("%d",&a[i]);

        printf("Sums of %d:\n",n);
        is_ok=0;
        Dfs(n,0,0);
        if(!is_ok) printf("NONE\n");
    }
    return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值