ZOJ 3543 Number String(dp)

Number String

Time Limit: 5 Seconds       Memory Limit: 65536 KB

The signature of a permutation is a string that is computed as follows: for each pair of consecutive elements of the permutation, write down the letter 'I' (increasing) if the second element is greater than the first one, otherwise write down the letter 'D' (decreasing). For example, the signature of the permutation {3,1,2,7,4,6,5} is "DIIDID".

Your task is as follows: You are given a string describing the signature of many possible permutations, find out how many permutations satisfy this signature.

Note: For any positive integer n, a permutation of n elements is a sequence of length n that contains each of the integers 1 through n exactly once.

Input

Each test case consists of a string of 1 to 1000 characters long, containing only the letters 'I', 'D' or '?', representing a permutation signature.

Each test case occupies exactly one single line, without leading or trailing spaces.

Proceed to the end of file. The '?' in these strings can be either 'I' or 'D'.

Output

For each test case, print the number of permutations satisfying the signature on a single line. In case the result is too large, print the remainder modulo 1000000007.

Sample Input
II
ID
DI
DD
?D
??
Sample Output
1
2
2
1
3
6
Hint

Permutation {1,2,3} has signature "II".
Permutations {1,3,2} and {2,3,1} have signature "ID".
Permutations {3,1,2} and {2,1,3} have signature "DI".
Permutation {3,2,1} has signature "DD".
"?D" can be either "ID" or "DD".
"??" gives all possible permutations of length 3.


Author:  HONG, Qize

Contest: The 2011 ACM-ICPC Asia Dalian Regional Contest


题意:给n个数(1~n),若后一个数大于前一个数则产生一个I,反正则产生一个D,若为?则都可以,根据产生的序列,问有多少种排列符合要求

题解:该题可以用dp来解,dp【i】【j】代表长度为 i 的排列(第一个到第 i 个)并以 j 这个数为结尾的排列的合法排列数

那么当长度为 i 且以 j 这个数为结尾(即第 i 位为数字 j )的排列怎么才算合法呢?

由于给定一个长度为i-1的字符串,由{1,2,...,i}组成的合法排列数和由{1,2,...,j-1,j+1,...,i+1},所以只需当前 i 个数是1~i 计算即可

明显是若这里的字符是 I 的话,第 i-1 个数字必须要小于 j 才能算是合法,那么就有递推公式,dp【i】【j】=dp【i-1】【1】+……+dp【i-1】【j-1】,换言之就是长度为 i-1 并且以1~(j-1)为结尾的合法排列数的和加起来就是 dp【i】【j】的值;

那么若这里的字符是 D 的话,第 i-1 个数字必须要大于 j 才能算是合法,那么就有递推公式,dp【i】【j】=dp【i-1】【j】+……+dp【i-1】【i-1】

其中?的时候也如此类推,最后sum【i】【j】数组代表长度为 i 的前 j 个dp值相加


#include<stdio.h>
#include<string.h>
#define mod 1000000007
long long dp[1005][1005],sum[1005][1005];
char s[1005];
int main()
{
    int n,i,j;

    while(scanf("%s",s+2)>0)
    {
        dp[1][1]=sum[1][1]=1;
        n=strlen(s+2)+1;
        for(i=2;i<=n;i++)
        {
            for(j=1;j<=n;j++)
            {
                if(s[i]=='I') dp[i][j]=sum[i-1][j-1];
                else if(s[i]=='D') dp[i][j]=sum[i-1][i-1]-sum[i-1][j-1];
                else dp[i][j]=sum[i-1][i-1];
                sum[i][j]=(sum[i][j-1]+dp[i][j])%mod;
            }
        }
        printf("%lld\n",(sum[n][n]+mod)%mod);
    }

    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值