HDU 1171 母函数

Big Event in HDU


 

Problem Description

 

Nowadays, we all know that Computer College is the biggest department in HDU. But, maybe you don't know that Computer College had ever been split into Computer College and Software College in 2002.
The splitting is absolutely a big event in HDU! At the same time, it is a trouble thing too. All facilities must go halves. First, all facilities are assessed, and two facilities are thought to be same if they have the same value. It is assumed that there is N (0<N<1000) kinds of facilities (different value, different kinds).
 


 

Input

 

Input contains multiple test cases. Each test case starts with a number N (0 < N <= 50 -- the total number of different facilities). The next N lines contain an integer V (0<V<=50 --value of facility) and an integer M (0<M<=100 --corresponding number of the facilities) each. You can assume that all V are different.
A test case starting with a negative integer terminates input and this test case is not to be processed.
 


 

Output

 

For each case, print one line containing two integers A and B which denote the value of Computer College and Software College will get respectively. A and B should be as equal as possible. At the same time, you should guarantee that A is not less than B.
 


 

Sample Input

 

  
  
2 10 1 20 1 3 10 1 20 2 30 1 -1
 


 

Sample Output

 

  
  
20 10 40 40


 

题意:有n种物品,每种物品的价格和数量已知,

现在要求将这些物品分成两份,使两份的总价值的差最小。

把设备排列组合,把所有可能的组合都打出来,

然后从总价值的中间开始搜,

只要搜到第一个,然后拆分开就是了

好像用动态规划更....

#include <iostream>
using namespace std;
int c1[111111],c2[111111];
int val[1111],num[1111];
int n;
int main()
{
	int i,j,k,len;
	while(~scanf("%d",&n),n>0)
	{
		int sum=0;
		for(i=1;i<=n;i++)
		{
			scanf("%d%d",&val[i],&num[i]);
			sum+=val[i]*num[i];//计算总价值
		}
		memset(c1,0,sizeof(c1));
		memset(c2,0,sizeof(c2));
		len=val[1]*num[1];
		for(i=0;i<=len;i+=val[1])//把那个价值存在的赋值1,其他的本来清零
			c1[i]=1;
		for(i=2;i<=n;i++)
		{
			for(j=0;j<=len;j++)
				for(k=0;k<=val[i]*num[i];k+=val[i])//k+=val[i]!!
					c2[k+j]+=c1[j];
			len+=val[i]*num[i];
			for(j=0;j<=len;j++)
				c1[j]=c2[j],c2[j]=0;
		}
		for(i=sum/2;i>=0;i--)//从中间开始搜索
		{
			if(c1[i]!=0)
			{
				printf("%d %d\n",sum-i,i);
				break;
			}
		}
	}
	return 0;
}


 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值