题目描述
给你三个正整数,a,m,b,你需要求:a^b mod m
输入输出格式
输入格式:
一行三个整数,a,m,b
对于全部数据:
1≤a≤10^9
1≤b≤10^{20000000}
1≤m≤10^6输出格式:
一个整数表示答案
输入输出样例
输入样例#1:
2 7 4
输出样例#1:
2
输入样例#2:
998244353 12345 98765472103312450233333333333
输出样例#2:
5333
思路:指数最大到 20000000,没有超出 long long 的范围,可以直接利用十进制快速幂来做
源代码
#include<iostream>
#include<cstdio>
#include<cstdlib>
#include<string>
#include<cstring>
#include<cmath>
#include<ctime>
#include<algorithm>
#include<utility>
#include<stack>
#include<queue>
#include<vector>
#include<set>
#include<map>
#include<bitset>
#define EPS 1e-9
#define PI acos(-1.0)
#define INF 0x3f3f3f3f
#define LL long long
#define Pair pair<int,int>
const int MOD = 31011;
const int N = 20000000+5;
const int dx[] = {0,0,-1,1,-1,-1,1,1};
const int dy[] = {-1,1,0,0,-1,1,-1,1};
using namespace std;
char b[N];
LL tenthPow(LL a,LL len,LL mod) {
LL res=1;
while(len>=0){
LL cnt=b[len]-'0';
LL cur=a;
for(int i=1; i<=cnt; i++)
res=res*a%mod;
for(int i=1; i<10; i++)
cur=cur*a%mod;
//进位
a=cur;
res%=mod;
len--;
}
return res;
}
int main(){
LL a,mod;
scanf("%lld",&a);
scanf("%lld",&mod);
scanf("%s",b);//字符串读入指数
LL len=strlen(b);
LL res=tenthPow(a,len-1,mod);
printf("%lld\n",res);
return 0;
}