Time Limit: 2000MS | Memory Limit: 65536K | |
Total Submissions: 46017 | Accepted: 14422 |
Description
Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.
* Walking: FJ can move from any point X to the points X - 1 or X + 1 in a single minute
* Teleporting: FJ can move from any point X to the point 2 × X in a single minute.
If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?
Input
Output
Sample Input
5 17
Sample Output
4
Hint
HDU做过,一模一样,BFS直接破
#include<stdio.h>
#include<queue>
#include<string>
using namespace std;
int s,e;
int vis[100010];
struct node
{
int cur,step;
};
int check(int x)
{
if(x<0||x>100000||vis[x])//这里要留意一下
return 0;
return 1;
}
int bfs()
{
memset(vis,0,sizeof(vis));
node a,nex;
queue<node>Q;
a.cur=s;
a.step=0;
vis[s]=1;
Q.push(a);
while(!Q.empty())
{
a=Q.front();
Q.pop();
if(a.cur==e)
return a.step;
if(check(a.cur-1))
{
nex.cur=a.cur-1;
nex.step=a.step+1;
vis[nex.cur]=1;
Q.push(nex);
}
if(check(a.cur+1))
{
nex.cur=a.cur+1;
nex.step=a.step+1;
vis[nex.cur]=1;
Q.push(nex);
}
if(check(a.cur*2))
{
nex.cur=a.cur*2;
nex.step=a.step+1;
vis[nex.cur]=1;
Q.push(nex);
}
}
return -1;
}
int main()
{
while(~scanf("%d%d",&s,&e))
{
printf("%d\n",bfs());
}
return 0;
}