HDU1195:Open the Lock(BFS)

Problem Description
Now an emergent task for you is to open a password lock. The password is consisted of four digits. Each digit is numbered from 1 to 9. 
Each time, you can add or minus 1 to any digit. When add 1 to '9', the digit will change to be '1' and when minus 1 to '1', the digit will change to be '9'. You can also exchange the digit with its neighbor. Each action will take one step.

Now your task is to use minimal steps to open the lock.

Note: The leftmost digit is not the neighbor of the rightmost digit.
 

Input
The input file begins with an integer T, indicating the number of test cases. 

Each test case begins with a four digit N, indicating the initial state of the password lock. Then followed a line with anotther four dight M, indicating the password which can open the lock. There is one blank line after each test case.
 

Output
For each test case, print the minimal steps in one line.
 

Sample Input
  
  
2 1234 2144 1111 9999
 

Sample Output
  
  
2 4


题目不难,BFS,代码有点长,嘛,部分代码都是复制黏贴的事

关键是状态记录,开个四维数组记录当前密码就好了


#include<stdio.h>
#include<queue>
#include<string>
using namespace std;
int pw[5];
int vis[11][11][11][11];
struct node
{
	int n[4],step;
}ini;
void bfs()
{
	int i;
	queue<node>Q;
	node nex,a;
	ini.step=0;
	vis[ini.n[0]][ini.n[1]][ini.n[2]][ini.n[3]]=1;
	Q.push(ini);
	while(!Q.empty())
	{
		a=Q.front();
		Q.pop();
		if(a.n[0]==pw[0]&&a.n[1]==pw[1]&&a.n[2]==pw[2]&&a.n[3]==pw[3])
		{
			printf("%d\n",a.step);
			return ;
		}
		//+1
		for(i=0;i<4;i++)
		{
			nex=a;
			nex.n[i]++;
			if(nex.n[i]>9)
				nex.n[i]=1;
			if(!vis[nex.n[0]][nex.n[1]][nex.n[2]][nex.n[3]])
			{
				vis[nex.n[0]][nex.n[1]][nex.n[2]][nex.n[3]]=1;
				nex.step++;
				Q.push(nex);
			}
		}
		//-1
		for(i=0;i<4;i++)
		{
			nex=a;
			nex.n[i]--;
			if(nex.n[i]<1)
				nex.n[i]=9;
			if(!vis[nex.n[0]][nex.n[1]][nex.n[2]][nex.n[3]])
			{
				vis[nex.n[0]][nex.n[1]][nex.n[2]][nex.n[3]]=1;
				nex.step++;
				Q.push(nex);
			}
		}
		//exchange
		for(i=0;i<3;i++)
		{
			nex=a;
			nex.n[i]=a.n[i+1];
			nex.n[i+1]=a.n[i];
			if(!vis[nex.n[0]][nex.n[1]][nex.n[2]][nex.n[3]])
			{
				vis[nex.n[0]][nex.n[1]][nex.n[2]][nex.n[3]]=1;
				nex.step++;
				Q.push(nex);
			}
		}
	}
	printf("-1\n");
}

int main()
{
	int t;
	char str1[5],str2[5];
	scanf("%d",&t);
	while(t--)
	{
		scanf("%s%s",str1,str2);
		for(int i=0;i<4;++i)
		{
			ini.n[i]=str1[i]-'0';
			pw[i]=str2[i]-'0';
		}
		memset(vis,0,sizeof(vis));
		bfs();
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值