HDU 2955 Robberies(01背包变型)

Description
The aspiring Roy the Robber has seen a lot of American movies, and knows that the bad guys usually gets caught in the end, often because they become too greedy. He has decided to work in the lucrative business of bank robbery only for a short while, before retiring to a comfortable job at a university.


For a few months now, Roy has been assessing the security of various banks and the amount of cash they hold. He wants to make a calculated risk, and grab as much money as possible.


His mother, Ola, has decided upon a tolerable probability of getting caught. She feels that he is safe enough if the banks he robs together give a probability less than this.
 

Input

The first line of input gives T, the number of cases. For each scenario, the first line of input gives a floating point number P, the probability Roy needs to be below, and an integer N, the number of banks he has plans for. Then follow N lines, where line j gives an integer Mj and a floating point number Pj .
Bank j contains Mj millions, and the probability of getting caught from robbing it is Pj .
 

Output

For each test case, output a line with the maximum number of millions he can expect to get while the probability of getting caught is less than the limit set.

Notes and Constraints
0 < T <= 100
0.0 <= P <= 1.0
0 < N <= 100
0 < Mj <= 100
0.0 <= Pj <= 1.0
A bank goes bankrupt if it is robbed, and you may assume that all probabilities are independent as the police have very low funds.
 

Sample Input

    
    
3 0.04 3 1 0.02 2 0.03 3 0.05 0.06 3 2 0.03 2 0.03 3 0.05 0.10 3 1 0.03 2 0.02 3 0.05
 

Sample Output

    
    
2 4 6
 

解题报告:题目大意是有个强盗要抢劫,这个强盗被抓的概率给了,然后总共有N个银行,每个银行都有一个可供抢劫的数额,还有一个被抓的概率。问这个强盗最多能够抢劫多少钱。由于强盗要如果抢劫两次,那么不被抓的概率就是(1-p1)*(1-p2),是相乘的关系。而且我们计算被抓的概率前都要计算不被抓的概率,所以不妨dp[i]为小偷抢劫到第i个银行时所累积的不被抓的概率,注意第i个银行不一定要抢。

#include <cstdio>
#include <cstring>
#define max(a, b) (a > b ? a : b)
int t, n, i, m[105], j, sum;
double up, p[105], dp[10005];
int main() {
    scanf("%d", &t);
    while (t --) {
        sum = 0;
        scanf("%lf%d", &up, &n);
        for (i = 0; i < n; i ++) {
            scanf("%d%lf", m + i, p + i);
            sum += m[i];
        }
        memset(dp, 0, sizeof(dp)), dp[0] = 1;
        for (i = 0; i < n; i ++) {
            for (j = sum; j >= m[i]; j --) {
               dp[j] = max(dp[j], (dp[j-m[i]]) * (1 - p[i]));
            }
        }
        for (i = sum; i >= 0; i --) {
            if(dp[i] > 1 - up) {
                printf("%d\n", i);
                break;
            }
        }
    }
    return 0;
}

最后一个等号

dp[i] >= 1 - up
似乎取不取都对,但是按照我的想法是1-dp[i] < up, 所以是不取。没有临界数据,所以都ac。

这一题的另外一种想法就是用dp[p*100]表示概率为p时的最大金额,可惜题目没说概率一定是两位小数,所以wa,但是还是贴上借来的代码。想法挺好。

#include <iostream>
#include <stdio.h>
#include <stdlib.h>
#include <limits.h>
#include <cstring>
#define MAX_N 110
using namespace std;

int dp[MAX_N];
double sum;
int T,num,result,sum1;
int c[MAX_N],w1[MAX_N];
double w[MAX_N];
int main()
{
    cin>>T;
    while( T-- )
    {
        scanf("%lf%d",&sum,&num);
        sum1=(int)(sum*100+0.5);
        for( int i = 0; i < num; i++ )
        {
            scanf("%d%lf",&c[i],&w[i]);
            w1[i]=(int)(w[i]*100+0.5);
        }
        memset(dp,0,sizeof(dp));result=0;
        for( int i = 0; i < num; i++ )
        {
            for( int j = sum1; j >= w1[i]; j-- )
            {
                dp[j]=max(dp[j],dp[j-w1[i]]+c[i]);
                result=max(dp[j],result);
            }
        }
        printf("%d\n",result);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值