POJ 1284 Primitive Roots(欧拉函数)

Primitive Roots
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 3319 Accepted: 1934

Description

We say that integer x, 0 < x < p, is a primitive root modulo odd prime p if and only if the set { (x i mod p) | 1 <= i <= p-1 } is equal to { 1, ..., p-1 }. For example, the consecutive powers of 3 modulo 7 are 3, 2, 6, 4, 5, 1, and thus 3 is a primitive root modulo 7. 
Write a program which given any odd prime 3 <= p < 65536 outputs the number of primitive roots modulo p. 

Input

Each line of the input contains an odd prime numbers p. Input is terminated by the end-of-file seperator.

Output

For each p, print a single number that gives the number of primitive roots in a single line.

Sample Input

23
31
79

Sample Output

10
8
24

题目大意:

一个整数x(0 < x < p) 是奇素数p的原根,当且仅当集合{(x ^ i mod p)} | 1 <= i <= p -1|与集合{1,....,p-1}是相同的.例如,3的连续次幂对7取模的结果是3,2,6,4,5,1,所以3是7的一个原根.给出一个奇素数p(3 <= p < 65536),编程求出p的原根的个数.


解题思路:

本题应用到一个结论:m是素数,则m有p(m-1)个原根,其中p(n)是指不超过n且与n互素的正整数个数.

AC代码:

#include<iostream>

using namespace std;

int phi(int n)
{
	int rea = n;
	for(int i=2;i * i <= n;i++)
	{
		if(n % i == 0)
		{
			rea = rea - rea / i;
			do
			n /= i;
			while(n % i == 0);
		}
	}	
	if(n > 1)
	{
		rea = rea - rea / n;
	}
	return rea;
}

int main()
{
	int m;
	while(scanf("%d",&m) != EOF && m)
	{
		int res = phi(m-1);
		printf("%d\n",res);
	}
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值