hdu5212 Code 莫比乌斯

Problem Description
WLD likes playing with codes.One day he is writing a function.Howerver,his computer breaks down because the function is too powerful.He is very sad.Can you help him?

The function:


int calc
{
  
  int res=0;
  
  for(int i=1;i<=n;i++)
    
    for(int j=1;j<=n;j++)
    
    {
      
      res+=gcd(a[i],a[j])*(gcd(a[i],a[j])-1);
      
      res%=10007;
    
    }
  
  return res;

}
 

Input
There are Multiple Cases.(At MOST  10 )

For each case:

The first line contains an integer  N(1N10000) .

The next line contains  N  integers  a1,a2,...,aN(1ai10000) .
 

Output
For each case:

Print an integer,denoting what the function returns.
 

Sample Input
  
  
5 1 3 4 2 4
 

Sample Output
  
  
64
Hint
gcd(x,y) means the greatest common divisor of x and y.
 

#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
int n;
int d[10005];
int num[10005];
long long mod=10007;
long long yin[10005];
int mu[10005],prime[10005],tot;
bool check[10005];
int mx;
void getmu()
{
    memset(check,0,sizeof(check));
    mu[1]=1,tot=0;
    for(int i=2;i<=mx;i++){
        if(!check[i])
            prime[tot++]=i,mu[i]=-1;
        for(int j=0;j<tot;j++){
            if(i*prime[j]>mx)
                break;
            check[i*prime[j]]=true;
            if(i%prime[j]==0){
                mu[i*prime[j]]=0;
                break;
            }
            else
                mu[i*prime[j]]=-mu[i];
        }
    }
}
int main()
{
    while(~scanf("%d",&n))
    {
        memset(yin,0,sizeof(yin));
        memset(num,0,sizeof(num));
        mx=0;
        for(int i=0;i<n;i++)
        {
            scanf("%d",&d[i]);
            mx=max(mx,d[i]);
            num[d[i]]++;
        }
        for(int i=1;i<=mx;i++)
        {
            for(int j=i;j<=mx;j+=i)
            {
                yin[i]+=num[j];
            }
        }
        for(int i=1;i<=mx;i++)
            yin[i]=yin[i]*yin[i];
        getmu();
        long long ans=0;
        for(int i=1;i<=mx;i++)
        {
            long long u=0;
            for(int j=i;j<=mx;j+=i)
            {
                u=(u+yin[j]*mu[j/i]%mod)%mod;
            }
            ans+=u*i%mod*(i-1)%mod;
        }
        ans=(ans+mod)%mod;
        printf("%I64d\n",ans);
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值