UVA 621 Secret Research

Secret Research
Time Limit:3000MS Memory Limit:0KB 64bit IO Format:%lld & %llu
Submit Status Practice UVA 621
Appoint description:

Description
Download as PDF

At a certain laboratory results of secret research are thoroughly encrypted. A result of a single experiment is stored as an information of its completion:

positive result',negative result’, experiment failed' orexperiment not completed’

The encrypted result constitutes a string of digits S, which may take one of the following forms:

positive result S = 1 or S = 4 or S = 78 negative result S = S35 experiment failed S = 9S4 experiment not completed S = 190S

(A sample result S35 means that if we add digits 35 from the right hand side to a digit sequence then we shall get the digit sequence corresponding to a failed experiment)

You are to write a program which decrypts given sequences of digits.

Input
A integer n stating the number of encrypted results and then consecutive n lines, each containing a sequence of digits given as ASCII strings.

Output
For each analysed sequence of digits the following lines should be sent to output (in separate lines):

  • for a positive result - for a negative result * for a failed experiment ? for a not completed experiment

In case the analysed string does not determine the experiment result, a first match from the above list should be outputted.

Sample Input

4
78
7835
19078
944

Sample Output

+

?
*
按照题意进行简单模拟

#include<iostream>
#include<algorithm>
#include<map>
#include<cstdio>
#include<cstdlib>
#include<vector>
#include<cmath>
#include<cstring>
#include<string>
using namespace std;
const int maxn=13;
typedef long long LL;

int main(){
//    #ifndef ONLINE_JUDGE
//    freopen("Text//in.txt","r",stdin);
//    #endif // ONLINE_JUDGE
    int n;
    while(cin>>n){
        for(int i=0;i<n;i++){
            string s;
        cin>>s;
        int m=s.size()-1;
        if(s=="1"||s=="4"||s=="78"){
            cout<<"+"<<endl;
        }
        else if(s[m]=='5'&&s[m-1]=='3'){
            cout<<"-"<<endl;
        }
        else if(s[0]=='9'&&s[m]=='4'){
            cout<<"*"<<endl;
        }
        else if(s[0]=='1'&&s[1]=='9'&&s[2]=='0'){
            cout<<"?"<<endl;
        }
        }
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值