复数类--重载运算符2+

Problem C: C++习题 复数类--重载运算符2+

[ Submit][ Status][ Web Board]

Description

定义一个复数类Complex,重载运算符“+”,使之能用于复数的加法运算。参加运算的两个运算量可以都是类对象,也可以其中有一个是整数,顺序任意。例如,c1+c2,i+c1,c1+i均合法(设i为整数,c1,c2为复数)。编写程序,分别求两个复数之和、整数和复数之和。

Input

两个复数 
一个复数和一个整数 
一个整数和一个复数

Output

两个复数之和、复数和整数之和,整数和复数之和。

Sample Input

3 4 5 -103 4 55 3 4

Sample Output

c1+c2=(8.00,-6.00i)c1+i=(8.00,4.00i)i+c1=(8.00,4.00i)

HINT


#include <iostream>
#include <iomanip>
using namespace std;
class Complex
{
public:
    Complex()
    {
        real=0;
        imag=0;
    }
    Complex(double r,double i)
    {
        real=r;
        imag=i;
    }
    Complex operator+(Complex &c2);
    Complex operator+(int &i);
    friend Complex operator+(int&,Complex &);
    void display();
private:
    double real;
    double imag;
};
Complex Complex::operator +(Complex &c)
{
    return Complex(real+c.real,imag+c.imag);
}
Complex Complex::operator +(int &i)
{
    return Complex(real+i,imag);
}
Complex operator+(int &i,Complex &c)
{
    return Complex(i+c.real,c.imag);
}

void Complex::display()
{
     
    cout<<"("<<real<<","<<imag<<"i)"<<endl;
}

int main()
{
    double real,imag;
    cin>>real>>imag;
    Complex c1(real,imag);
    cin>>real>>imag;
    Complex c2(real,imag);
    cout<<setiosflags(ios::fixed);
    cout<<setprecision(2);
    Complex c3=c1+c2;
    cout<<"c1+c2=";
    c3.display();
    int i;
    cin>>real>>imag;
    cin>>i;
    c3=Complex(real,imag)+i;
    cout<<"c1+i=";
    c3.display();
    cin>>i;
    cin>>real>>imag;
    c1=Complex(real,imag);
    c3=i+c1;
    cout<<"i+c1=";
    c3.display();
    return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值