UVA 270 Lining Up(多点共线)

16 篇文章 0 订阅
 Lining Up
Time Limit:3000MS     Memory Limit:0KB     64bit IO Format:%lld & %llu

Description

Download as PDF


 Lining Up 

``How am I ever going to solve this problem?" said the pilot.

Indeed, the pilot was not facing an easy task. She had to drop packages at specific points scattered in a dangerous area. Furthermore, the pilot could only fly over the area once in a straight line, and she had to fly over as many points as possible. All points were given by means of integer coordinates in a two-dimensional space. The pilot wanted to know the largest number of points from the given set that all lie on one line. Can you write a program that calculates this number?

Your program has to be efficient!

Input

The input begins with a single positive integer on a line by itself indicating the number of the cases following, each of them as described below. This line is followed by a blank line, and there is also a blank line between two consecutive inputs.
The input consists of N pairs of integers, where 1 < N < 700. Each pair of integers is separated by one blank and ended by a new-line character. The list of pairs is ended with an end-of-file character. No pair will occur twice.

Output

For each test case, the output must follow the description below. The outputs of two consecutive cases will be separated by a blank line. 
The output consists of one integer representing the largest number of points that all lie on one line.

Sample Input

1

1 1
2 2
3 3
9 10
10 11

Sample Output

3
 
   
给你一定坐标,以空格结束,问最多有多少点在一条直线上
我们知道两点确定一条直线,然后我们可以依次判断剩下的点是否在这条直线上。
两点式求出直线的方程,带入第三点判断即可,为了方便计算,转化为乘积形式(y2-y1)*(x2-x3)=(x2-x1)*(y2-y3)
#include <iostream>
#include <cstdio>
#include <cstring>
#include <stdlib.h>
#include <map>
#define N 1000010
using namespace std;
int x[N];
int y[N];
char str[10];
int main()
{
    int T;
    scanf("%d%*c",&T);
    gets(str);
    while(T--)
    {
        int ans=1;
        int s=0;
        while(gets(str))
        {
            if(str[0]=='\0') break;
            sscanf(str,"%d%d",&x[s],&y[s]);  // 从一个字符串中读进与指定格式相符的数据
           s++;
        }
        for(int i=0; i<s; i++)
        {
           for(int j=i+1;j<s;j++)
           {
               int sum=2;
               for(int k=j+1;k<s;k++)
               {
                   if((y[j]-y[i])*(x[j]-x[k]) == (x[j]-x[i])*(y[j]-y[k]))
                    sum++;
               }
               ans=max(ans,sum);
           }
        }
        printf("%d\n",ans);
        if(T) printf("\n");
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值