Prime Time

Euler is a well-known matematician, and, among many other things, he discovered that the formula n 2 + n + 41 produces a prime for 0 ≤ n < 40. For n = 40, the formula produces 1681, which is 41 ∗ 41. Even though this formula doesn’t always produce a prime, it still produces a lot of primes. It’s known that for n ≤ 10000000, there are 47,5% of primes produced by the formula! So, you’ll write a program that will output how many primes does the formula output for a certain interval. Input Each line of input will be given two positive integer a and b such that 0 ≤ a ≤ b ≤ 10000. You must read until the end of the file. Output For each pair a, b read, you must output the percentage of prime numbers produced by the formula in this interval (a ≤ n ≤ b) rounded to two decimal digits.

Sample Input

0 39

0 40

39 40

Sample Output

100.00

97.56

50.00

#include<stdio.h>

’#include<math.h>

#include<string.h>

int su[10005];

int judge(int n) //判断素数

{

int i;

for(i = 2;i<=sqrt(n); i++)

{

if(n % i == 0)

return 0;

}

return 1;

}

int main()

{

int i;

for(i = 0 ; i <= 10005 ; i++)

{

su[i]=judge(i*i+i+41);//计算i*i+i+41是素数的话存入su[i];

}

int a,b;

while(scanf("%d %d",&a,&b)!=EOF) //输入两个范围

{

double sum=0;

for(i = a ; i <= b ; i++)

{

sum+=su[i];//判断su[i]是素数就想加,记录

}

printf("%.2f\n",sum*1.0/(b-a+1)*100+1e-8);

}

return 0;

}

 

             

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值