第十二届浙江省大学生程序设计大赛-Ace of Aces 分类: 比赛...

Ace of Aces
Time Limit: 2 Seconds Memory Limit: 65536 KB

There is a mysterious organization called Time-Space Administrative Bureau (TSAB) in the deep universe that we humans have not discovered yet. This year, the TSAB decided to elect an outstanding member from its elite troops. The elected guy will be honored with the title of “Ace of Aces”.

After voting, the TSAB received N valid tickets. On each ticket, there is a number Ai denoting the ID of a candidate. The candidate with the most tickets nominated will be elected as the “Ace of Aces”. If there are two or more candidates have the same number of nominations, no one will win.

Please write program to help TSAB determine who will be the “Ace of Aces”.
Input

There are multiple test cases. The first line of input contains an integer T indicating the number of test cases. For each test case:

The first line contains an integer N (1 <= N <= 1000). The next line contains N integers Ai (1 <= Ai <= 1000).
Output

For each test case, output the ID of the candidate who will be honored with “Ace of Aces”. If no one win the election, output “Nobody” (without quotes) instead.
Sample Input

3
5
2 2 2 1 1
5
1 1 2 2 3
1
998

Sample Output

2
Nobody
998

#include <bits/stdc++.h>

using namespace std;

struct node
{
    int sum;
    int pos;
}po[1100];

bool cmp(node a,node b)
{
    return a.sum>b.sum;
}

int main()
{
    int t,n,i,a;
    bool flag;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d",&n);
        flag=true;
        memset(po,0,sizeof(po));
        for(i=0; i<n; i++)
        {
            scanf("%d",&a);
            po[a].sum++;
            po[a].pos=a;

        }
        sort(po,po+1001,cmp);
        for(i=1 ;i<=1000 ;i++)
        {
            if(po[i].sum==po[0].sum)
            {
                flag=false;
                break;
            }

        }
        //cout<<po[0].pos<<endl;
        if(flag)
        {
            printf("%d\n",po[0].pos);
        }
        else
        {
            printf("Nobody\n");
        }
    }
    return 0;
}

版权声明:本文为博主原创文章,未经博主允许不得转载。

转载于:https://www.cnblogs.com/juechen/p/4721979.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值