C++中vector的用法

1.vector的基本用法

/*----------------------------------
功能:vector的用法
输入示例:
Input the number of data: 3
Input your data: 1.2 3.4 6.8
输出示例:
The average of numbers in arr = 3.8
------------------------------------
Author: Zhang Kaizhou
Date: 2019-4-3 11:15:29
-----------------------------------*/
#include <iostream>
#include <vector>

using namespace std;

double average(const vector<double> &arr);

int main(){
    unsigned int n;
    cout << "Input the number of data: ";
    cin >> n;
    vector<double> arr(n); // 利用vector类模板创建一个类成员类型为double类型的类的数组对象arr,长度为n
    cout << "Input your data: ";
    for(unsigned int i = 0; i < n; i++){
        cin >> arr[i];
    }
    cout << "The average of numbers in arr = " << average(arr) << endl;

    return 0;
}

double average(const vector<double> &arr){ // 对象引用作为形参
    double sum =
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值