Doing Homework again hdu1789贪心

Ignatius has just come back school from the 30th ACM/ICPC. Now he has a lot of homework to do. Every teacher gives him a deadline of handing in the homework. If Ignatius hands in the homework after the deadline, the teacher will reduce his score of the final test. And now we assume that doing everyone homework always takes one day. So Ignatius wants you to help him to arrange the order of doing homework to minimize the reduced score.

Input

The input contains several test cases. The first line of the input is a single integer T that is the number of test cases. T test cases follow. 
Each test case start with a positive integer N(1<=N<=1000) which indicate the number of homework.. Then 2 lines follow. The first line contains N integers that indicate the deadlines of the subjects, and the next line contains N integers that indicate the reduced scores. 

Output

For each test case, you should output the smallest total reduced score, one line per test case. 

Sample Input

3
3
3 3 3
10 5 1
3
1 3 1
6 2 3
7
1 4 6 4 2 4 3
3 2 1 7 6 5 4

Sample Output

0
3
5

分数由大到小 日期由小到大  搜索从死线开始搜 这样保证刚好在死线的时候完成作业

#include<iostream>
#include<cstring>
#include<cstdio>
#include<algorithm>
using namespace std;

struct Work
{
	int dl;
	int ds;
}  work[1010];

int visit[1010];

bool cmp(Work a,Work b)
{
	if(a.ds!=b.ds) return a.ds>b.ds;
	else return a.dl<b.dl;
}

int main()
{
	int t;
	cin>>t;
	while(t--)
	{
		memset(visit,0,sizeof(visit));
		int n,j=0,score=0;
		cin>>n;
		for(int i=0;i<n;i++)
		{
			scanf("%d",&work[i].dl);
		}
		for(int i=0;i<n;i++)
		{
			scanf("%d",&work[i].ds);
		}
		
		sort(work,work+n,cmp);
		/*for(int i=0;i<n;i++)
		{
			cout<<"dl"<<work[i].dl<<"\tds"<<work[i].ds<<endl;
		}*/
		for(int i=0;i<n;i++)
		{
			for(j=work[i].dl;j>0;j--)//从死线开始搜索 
			{
				if(!visit[j]) 
				{
					visit[j]=true;
					break;
				}
			}
			if(j==0)//如果找不到时间来完成就罚分 
			{
				score+=work[i].ds;
			}
		}
		cout<<score<<endl;
	}
	return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值