People in Mars represent the colors in their computers in a similar way as the Earth people. That is, a color is represented by a 6-digit number, where the first 2 digits are for Red
, the middle 2 digits for Green
, and the last 2 digits for Blue
. The only difference is that they use radix 13 (0-9 and A-C) instead of 16. Now given a color in three decimal numbers (each between 0 and 168), you are supposed to output their Mars RGB values.
Input Specification:
Each input file contains one test case which occupies a line containing the three decimal color values.
Output Specification:
For each test case you should output the Mars RGB value in the following format: first output #
, then followed by a 6-digit number where all the English characters must be upper-cased. If a single color is only 1-digit long, you must print a 0
to its left.
Sample Input:
15 43 71
Sample Output:
#123456
#include<iostream>
#include<cmath>
#include<string.h>
#include<cstdio>
#include<queue>
#include<vector>
using namespace std;
typedef long long ll;
int main(){
int a[3]={0};
cin>>a[2]>>a[1]>>a[0];
printf("#");
int m=3;
while(m--)
{
int flag=0;int t=0;
int r=a[m]%13;
int l=a[m]/13;
if(l==10){
flag=1;printf("A");
}
if(l==11){
flag=1;printf("B");
}
if(l==12){
flag=1;printf("C");
}
if(flag==0)printf("%d",l);
if(r==10){
t=1;printf("A");
}
if(r==11){
t=1;printf("B");
}
if(r==12){
t=1;printf("C");
}
if(t==0)printf("%d",r);
}
}