People in Mars represent the colors in their computers in a similar way as the Earth people. That is, a color is represented by a 6-digit number, where the first 2 digits are for Red
, the middle 2 digits for Green
, and the last 2 digits for Blue
. The only difference is that they use radix 13 (0-9 and A-C) instead of 16. Now given a color in three decimal numbers (each between 0 and 168), you are supposed to output their Mars RGB values.
Input Specification:
Each input file contains one test case which occupies a line containing the three decimal color values.
Output Specification:
For each test case you should output the Mars RGB value in the following format: first output #
, then followed by a 6-digit number where all the English characters must be upper-cased. If a single color is only 1-digit long, you must print a 0
to its left.
Sample Input:
15 43 71
Sample Output:
#123456
题意:输入十进制数,输出十三进制,不足两位的,左边补0;
AC代码
#include<iostream>
using namespace std;
void jz(int n){
int a[100];
int t = 0;
while(n > 0){
a[t++] = n%13;
n /= 13;
}
if(t < 2){
for(int i = 0; i < 2-t; i++){
cout << 0;
}
}
for(int i = t-1; i >= 0; i--){
if(a[i] > 9){
printf("%c", 'A'+(a[i]-10));
}
else{
printf("%d", a[i]);
}
}
}
int main(){
int a, b, c;
cin >> a >> b >> c;
cout << "#";
jz(a);
jz(b);
jz(c);
return 0;
}