浙大 | PTA 习题8-7 字符串排序 (20分)

本题要求编写程序,读入5个字符串,按由小到大的顺序输出。

输入格式:

输入为由空格分隔的5个非空字符串,每个字符串不包括空格、制表符、换行符等空白字符,长度小于80。

输出格式:

按照以下格式输出排序后的结果:

After sorted:
每行一个字符串

输入样例:

red yellow blue green white

输出样例:

After sorted:
blue
green
red
white
yellow
#include <stdio.h>
#include <string.h>
#define MAXS 81

int main(void)
{
    char temp [5][MAXS];
    for(int i =0; i < 5; i++) // 读取数据
        scanf("%s",temp[i]);
    char ptrc[MAXS];

	
    for (int i =0; i < 5 - 1; i++) //排序
        for (int j = 0; j < 5-1-i;j++)
            if (strcmp(temp[j], temp[j+1]) > 0) //不能直接复制字符串,要用strcpy函数来复制
            {
                strcpy(ptrc,temp[j]);
                strcpy(temp[j], temp[j+1]);
                strcpy(temp[j+1], ptrc);
            }   
          
    
    printf("After sorted:\n"); //输出
    for (int i = 0; i < 5; i++)
        printf("%s\n", temp[i]);


    return 0;
}
  • 1
    点赞
  • 10
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值