题目内容
The highest building in our city has only one elevator. A request list is made up with N positive numbers. The numbers denote at which floors the elevator will stop, in specified order. It costs 6 seconds to move the elevator up one floor, and 4 seconds to move down one floor. The elevator will stay for 5 seconds at each stop.
For a given request list, you are to compute the total time spent to fulfill the requests on the list. The elevator is on the 0th floor at the beginning and does not have to return to the ground floor when the requests are fulfilled.
Input Specification:
Each input file contains one test case. Each case contains a positive integer N, followed by N positive numbers. All the numbers in the input are less than 100.
Output Specification:
For each test case, print the total time on a single line.
Sample Input:
3 2 3 1
Sample Output:
41
一、题干大意
电梯最开始停在0层,每次上升一楼需要6秒,下降一层需要4秒,每层停留5秒。现在给出一个需要停留的楼层列表(第一个数是表示列表一共有几个数),请你算出总共需要多长时间(无需返回第0层)。
二、题解要点
- 用一个now变量来保存现在电梯的层数,如果比now小就移动层数×4秒,比now大就移动层数×6秒
- 每次移动完后改变now的值
- 最后把一共停留了几次×5,算出总值。
三、具体实现
#include<iostream>
using namespace std;
int main() {
int n;
cin >> n;
int now = 0, total = 0;
for (int i = 0; i < n; ++i) {
int temp;
cin >> temp;
if (temp > now) {
total += (temp - now) * 6;
} else {
total += (now - temp) * 4;
}
now = temp;
}
total += n * 5;
cout << total << endl;
return 0;
}
总结
一开始没看见第一个数是用来表示一共有几层需要停留的,所以浪费了点时间,说明读题还是要仔细一点,尤其是这种英语题目。