求素数——含素筛方法

实际上,素筛算是一个相对来说挺简单的方法,但我之前一直都是凭自己的一些理解而写代码,于是决定在来系统的学习一下。
一般来说,我们判断一个数是否是素数,一般是看这个数除了1与本身之外是否是否还有因子,核心代码如下

int n,i;
scanf("%d",&n);
for(i=2;i<n;i++){
	if(n%i==0)break;
}
if(i>=n)printf("ture");

当然,这个方法判断的明显太多了,完全不用从2判断到n-1的,实际上如果非素数a=i*j;i<=j,很明显由于一个数如果有一个大因子,那它必然还有一个小因子,而小因子i<=sqrt(a);所以说,只要从2枚举到sqrt(a)就行了。代码如下:

int n,i,x;
scanf("%d",&n);
x=(int)sqrt(n);
for(i=2;i<=x;i++){
	if(n%i==0)break;
}
if(i>=n)printf("ture");

实际上,如果你判断多个素数,那你实际上只要打表就行了。打表是是什么,就是你先打出一张素数表,之后每次你就只有在表中查一下它是不是素数就可以了。而打表的方法是这样的:开始的时候,你先令所有的数为素数,然后将非素数从素数表中筛去:方法见以下代码

#include<cstdio>
#include<cstring>
bool Pri[100010];       //一般这么大够了,代表从1筛到100000
void prime(){
	memset(Pri,0,sizeof(Pri));
	int i,j;
	Pri[1]=1;           //1不是素数 
	for(i=2;i*i<=100000;i++){        //2到100000的非素数必然含有2到sqrt(i)的因子 
		if(Pri[i]==0){
			for(j=i*i;j<=100000;j+=i){    //因为如果j=i*p,p<i开始,实际上以p为因子的非素数已经被筛了一次 ,不用再筛了 
				Pri[j]=1;
			}
		}
	}
}
int main()
{
	prime();
	int n;
	while((scanf("%d",&n))>=1){          //不同题目要求结束方式不一样 
		if(Pri[n]==0)printf("ture\n");
		else printf("false\n");
	}
	return 0;
} 

当然,理解本质是最重要的,下面有一道题:
To improve the organization of his farm, Farmer John labels each of his N (1 <= N <= 5,000) cows with a distinct serial number in the range 1…20,000. Unfortunately, he is unaware that the cows interpret some serial numbers as better than others. In particular, a cow whose serial number has the highest prime factor enjoys the highest social standing among all the other cows.

(Recall that a prime number is just a number that has no divisors except for 1 and itself. The number 7 is prime while the number 6, being divisible by 2 and 3, is not).

Given a set of N (1 <= N <= 5,000) serial numbers in the range 1…20,000, determine the one that has the largest prime factor.
Input

  • Line 1: A single integer, N

  • Lines 2…N+1: The serial numbers to be tested, one per line
    Output

  • Line 1: The integer with the largest prime factor. If there are more than one, output the one that appears earliest in the input file.
    Sample Input
    4
    36
    38
    40
    42
    Sample Output
    38
    Sponsor
    上面题目的意思是求几个数中素数因子最大的数,实际上可以用打表来做,怎么做呢:
    首先原来的表意思:素数是0,非素数是1.
    而现在,素数是本身,非素数是最大质因数。
    所以从2开始,找到质数,然后一直往上,寻找他的倍数,而他的倍数的质因数便重置为该质数,由于我们这样遍历,后面的质数一定大于前面的质数,所以可以直接赋值。还有一点,这个表记得质数要置为自己,并且内层循环不能从i*i开始,而要从i开始,因为这个后面的质数更大。
    代码如下:

#include<cstdio>
#include<cstring> 
int maxpri[20010];
void maxp()
{
	int i,j;
	memset(maxpri,0,sizeof(maxpri));
	maxpri[1]=1;
	for(i=2;i<=20005;i++){
		if(maxpri[i]==0){
			for(j=i;j<=20005;j+=i){
				maxpri[j]=i;            //不断替换,由素数找倍数,后面素数大于前面的 
			}
		}
	}
}
int main()
{
	maxp();
	int n,i,p,tprim;
	while((scanf("%d",&n))>0){            //输入n,代表接下来输入n个数 
	int max=0,how=0;
	for(i=0;i<n;i++){
		scanf("%d",&p);        //输入这n个数 
		tprim=maxpri[p];       //取最大素数 
		if(tprim>max){
			max=tprim;         //保存最大素数 
			how=p;             //保存含最大素因子的数 
		}
	}
	printf("%d\n",how);
}
	return 0;
}
  • 2
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值