PAT-A1065 A+B and C (长整型比较)

A1065 A+B and C (长整型比较)

Given three integers A, B and C in (−263,263), you are supposed to tell whether A+B>C.

Input Specification:

The first line of the input gives the positive number of test cases, T (≤10). Then T test cases follow, each consists of a single line containing three integers A, B and C, separated by single spaces.

Output Specification:

For each test case, output in one line Case #X: true if A+B>C, or Case #X: false otherwise, where X is the case number (starting from 1).

Sample Input:

3
1 2 3
2 3 4
9223372036854775807 -9223372036854775808 0结尾无空行

Sample Output:

Case #1: false
Case #2: true
Case #3: false结尾无空行

Thanks to Jiwen Lin for amending the test data.

题意:

T(≤10)次循环,每次给三个数a,b,c

如果a+b>c,就输出Case #X: true

否则,就输出Case #X: false

分析:

1.接收值,经分析要长整型储存,同时也用长整型来存储a+b的值res

2.分别判断以下四种情况:

  • 正溢出,输出Case #X: true

  • 负溢出,输出Case #X: false

  • a+b>c,输出Case #X: true

  • a+b<=c,输出Case #X: false

相关知识点:
int类型的表示范围:[-2^31 —2^31-1]
long long数据类型:[-2^63 —2^63) long long类型用%lld来接收
正溢出:a>0,b>0,a+b<0
负溢出:a<0,b<0,a+b>=0

T次循环的另一种写法:while(T–){}

代码如下:

#include<cstdio>
int main(){
	int T;
	scanf("%d",&T);
	int i=1;
	while(T--){
		long long a,b,c;
		scanf("%lld %lld %lld",&a,&b,&c);
		long long res=a+b;
		if(a>0&&b>0&&res<0) printf("Case #%d: true\n",i);
		else if(a<0&&b<0&&res>=0) printf("Case #%d: false\n",i);
		     else if(res>c) printf("Case #%d: true\n",i);
		          else printf("Case #%d: false\n",i);
		i++;
	}
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值